Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Probleme mit Bedingter Formatierung
#1
Hallo zusammen

Ich beschäftige mich seit einiger Zeit mit Excel und habe mir selber mal die Aufgabe gegeben eine Arbeitsmappe zur Stundenberechnung mit Kalender, Feiertagen, Ferien, Urlaub usw. zu erstellen.
Ja es gibt fertige Mappen zum Download, aber genau das soll es nicht sein. Ich möchte durch das erstellen dieser Mappe Excel verstehen und lernen.
Über jeden Hinweis oder Erklärungen was man ändern oder besser machen könnte wäre ich dankbar.

Zur Zeit liegt mein Problem an der bedingten Formatierung. Ich möchte die Feiertage im Kalender farblich unterlegen.
In einer anderen Mappe habe ich so etwas mal gemacht und es funktionierte ohne Probleme.
In der jetzigen Mappe leider nicht. Zeitweise hatte ich eine bedingte Formatierung, die mir im Kalender allerdings andere Tage als die Feiertage formatierte und auch vielmehr als in meinem Arbeitsblatt angeben waren.

Die Wochenenden habe ich mit dieser Formel formatiert: =WOCHENTAG(A3;2)>5

Hier mal der Kalender in Kurzform:
A
12014
2Januar
3Mi. 01.01
4Do. 02.01
5Fr. 03.01
6Sa. 04.01
7So. 05.01
8Mo. 06.01
9Di. 07.01
Formeln der Tabelle
ZelleFormel
A1=Grundeinstellung!E3
A2=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-1))=SPALTE();DATUM($A$1;SPALTE();ZEILE()-1);"")
A3=DATUM(A1;SPALTE();ZEILE()-2)
A4=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")
A5=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")
A6=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")
A7=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")
A8=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")
A9=WENN(MONAT(DATUM($A$1;SPALTE();ZEILE()-2))=MONAT(A$2); DATUM($A$1;SPALTE();ZEILE()-2);
"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Das wäre die Feiertagsliste. Bitte nicht wundern es ist vieles was ich mal ausprobiert habe.

Feiertage

BCDEF
12014Deutschland
2
301.01.2014NeujahrMi. 01.01.2014x
402.02.2014Mariä LichtmeßSo. 02.02.2014x
506.01.2014Hl. Drei KönigeMo. 06.01.2014x
627.02.2014AltweiberfastnachtDo. 27.02.2014x
703.03.2014RosenmontagMo. 03.03.2014x
804.03.2014FastnachtDi. 04.03.2014x
905.03.2014AschermittwochMi. 05.03.2014x
1025.03.2014Mariä VerkündungDi. 25.03.2014x
1116.04.2014GründonnerstagMi. 16.04.2014x
1218.04.2014KarfreitagFr. 18.04.2014x
1320.04.2014OstersonntagSo. 20.04.2014x
1421.04.2014OstermontagMo. 21.04.2014x
1501.05.2014Tag der ArbeitDo. 01.05.2014x
1629.05.2014Christi HimmelfahrtDo. 29.05.2014x
1711.05.2014MuttertagSo. 11.05.2014x
1808.06.2014PfingstsonntagSo. 08.06.2014x
1909.06.2014PfingstmontagMo. 09.06.2014x
2019.06.2014FronleichnamDo. 19.06.2014x
Formeln der Tabelle
ZelleFormel
C1=Grundeinstellung!E3
B3=WENN(F3="x";D3;0)
D3=DATWERT("01.01."&$C$1)
B4=WENN(F4="x";D4;0)
D4=DATUM(C$1;2;2)
B5=WENN(F5="x";D5;0)
D5=DATUM(C$1;1;6)
B6=WENN(F6="x";D6;0)
D6=D$13-52
B7=WENN(F7="x";D7;0)
D7=D$13-48
B8=WENN(F8="x";D8;0)
D8=D$13-47
B9=WENN(F9="x";D9;0)
D9=D$13-46
B10=WENN(F10="x";D10;0)
D10=DATUM(C$1;3;25)
B11=WENN(F11="x";D11;0)
D11=D$12-2
B12=WENN(F12="x";D12;0)
D12=D$13-2
B13=WENN(F13="x";D13;0)
D13=DM((TAG(MINUTE(C$1/38)/2+55)&".4."&C$1)/7;)*7-6
B14=WENN(F14="x";D14;0)
D14=D$13+1
B15=WENN(F15="x";D15;0)
D15=DATUM(C$1;5;1)
B16=WENN(F16="x";D16;0)
D16=D$13+39
B17=WENN(F17="x";D17;0)
D17=DATUM(C$1;5;1)+15-WOCHENTAG(DATUM(C$1;5;1))
B18=WENN(F18="x";D18;0)
D18=D$13+49
B19=WENN(F19="x";D19;0)
D19=D$13+50
B20=WENN(F20="x";D20;0)
D20=D$13+60

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Danke
Gruß

Lümmel
Antwortento top
#2
Hola,

Zitat:In einer anderen Mappe habe ich so etwas mal gemacht und es funktionierte ohne Probleme.
In der jetzigen Mappe leider nicht.

Leider sehen wir nicht, wie du es probiert hast. Eine Beispieldatei macht mehr Sinn als Screenshots.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Lümmel
Antwortento top
#3
Hallo,

im Prinzip so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
101.01.2014
202.01.2014
303.01.2014
404.01.2014
505.01.2014
606.01.2014
707.01.2014

Zellebedingte Formatierung...Format
A11: =ZÄHLENWENN($C$1:$C$10;A1)>0abc
A21: =ZÄHLENWENN($C$1:$C$10;A2)>0abc
A31: =ZÄHLENWENN($C$1:$C$10;A3)>0abc
A41: =ZÄHLENWENN($C$1:$C$10;A4)>0abc
A51: =ZÄHLENWENN($C$1:$C$10;A5)>0abc
A61: =ZÄHLENWENN($C$1:$C$10;A6)>0abc
A71: =ZÄHLENWENN($C$1:$C$10;A7)>0abc
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top
#4
Hallo

wenn nur die mit "x" gekennzeichneten Tage als Feiertag erkannt werden sollen, dann würde ich diese Formel für die Bedingte Formatierung der Feiertage nehmen:

=INDEX($A$4:$E$20;VERGLEICH(A3;$A$4:$A$20;0);5)="x"
Gruß Atilla
Antwortento top
#5
Hi André, das >0 brauchts nicht...
(10.12.2014, 22:31)schauan schrieb: Hallo,

im Prinzip so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
101.01.2014
202.01.2014
303.01.2014
404.01.2014
505.01.2014
606.01.2014
707.01.2014

Zellebedingte Formatierung...Format
A11: =ZÄHLENWENN($C$1:$C$10;A1)>0abc
A21: =ZÄHLENWENN($C$1:$C$10;A2)>0abc
A31: =ZÄHLENWENN($C$1:$C$10;A3)>0abc
A41: =ZÄHLENWENN($C$1:$C$10;A4)>0abc
A51: =ZÄHLENWENN($C$1:$C$10;A5)>0abc
A61: =ZÄHLENWENN($C$1:$C$10;A6)>0abc
A71: =ZÄHLENWENN($C$1:$C$10;A7)>0abc
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#6
Sorry hier mal die Mappe

Die Formeln von der bedingten Formatierung stimmen soweit nicht mehr, da ich alles mögliche ausprobiert habe.
Gruß

Lümmel
Antwortento top
#7
(10.12.2014, 22:41)Jockel schrieb: Hi André, das >0 brauchts nicht...
(10.12.2014, 22:31)schauan schrieb: Hallo,

im Prinzip so:

Arbeitsblatt mit dem Namen 'Tabelle1'
 A
101.01.2014
202.01.2014
303.01.2014
404.01.2014
505.01.2014
606.01.2014
707.01.2014

Zellebedingte Formatierung...Format
A11: =ZÄHLENWENN($C$1:$C$10;A1)>0abc
A21: =ZÄHLENWENN($C$1:$C$10;A2)>0abc
A31: =ZÄHLENWENN($C$1:$C$10;A3)>0abc
A41: =ZÄHLENWENN($C$1:$C$10;A4)>0abc
A51: =ZÄHLENWENN($C$1:$C$10;A5)>0abc
A61: =ZÄHLENWENN($C$1:$C$10;A6)>0abc
A71: =ZÄHLENWENN($C$1:$C$10;A7)>0abc
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
Die Funktion Zählenwenn habe ich zuerst ausprobiert. Leider auch hier das Problem das die Tage im Kalender nicht markiert werden.

Ich hoffe einfach mal das ich hier nur einen Denkfehler habe und sich das Problem von selber löst.
Gruß

Lümmel
Antwortento top
#8
Hola,

die Lösung steht ja quasi schon hier im Thread:

Code:
=zählenwenn(Feiertage!$B$3:$B$39;B6)

Gruß,
steve1da
Antwortento top
#9
(10.12.2014, 22:41)atilla schrieb: Hallo

wenn nur die mit "x" gekennzeichneten Tage als Feiertag erkannt werden sollen, dann würde ich diese Formel für die Bedingte Formatierung der Feiertage nehmen:

=INDEX($A$4:$E$20;VERGLEICH(A3;$A$4:$A$20;0);5)="x"

Vielen Dank Steve1da,

für deine Hilfe. Leider funktioniert diese Formel auch nicht.
Oder ich bin mittlerweile Formel geschädigt 92
Gruß

Lümmel
Antwortento top
#10
Sorry meinte attila.
Aber auch die Formel =zählenwenn(Feiertage!$B$3:$B$39;B6) @steve1da klappt nicht.


Gruß

Lümmel
Gruß

Lümmel
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste