Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Bezugsfehler
#1
Hallo zusammen,

leider komme ich einfach nicht dahinter, warum in meiner Formel ein Bezugsfehler angezeigt wird.
Wer weiß warum das so ist?

Lieben Dank!


Angehängte Dateien
.xlsx   Test- Kontenübersicht.xlsx (Größe: 19,55 KB / Downloads: 16)
Antwortento top
#2
Hallo,

schau dir mal die Formel in der Formelauswertung an und du stellst fest, dass du im Index die Matrix von $G$6:$AP$13 verwendest. Bei der Zeile kommt in der Formel von G14 eine 9 heraus und hier ist das Problem: Deine Matrix umfasst lediglich 8 Zeilen.
Gruß
Peter
[-] Folgende(r) 1 Benutzer sagt Danke an Peter für diesen Beitrag:
  • veve
Antwortento top
#3
Hallo, außerdem würde ich einige Formeln wohl anders schreiben. So wie hier..:

Arbeitsblatt mit dem Namen 'Haushaltskostenstellen'
 F
6-8,00 €
7-1,00 €

ZelleFormel
F6=SUMMEWENN($G$5:AP$5;$I$5;$G6:$AP6)
F7=I7+L7+O7+R7+U7+X7+AA7+AD7+AG7+AJ7+AM7+AP7
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • veve
Antwortento top
#4
(23.09.2014, 11:42)Peter schrieb: Hallo,

schau dir mal die Formel in der Formelauswertung an und du stellst fest, dass du im Index die Matrix von $G$6:$AP$13 verwendest. Bei der Zeile kommt in der Formel von G14 eine 9 heraus und hier ist das Problem: Deine Matrix umfasst lediglich 8 Zeilen.

Wo finde ich bei Excel für Mac die Formelauswertung? Bei Windows war diese bei Extras, ich kann hier leider nur Spur zum Vorgänger/Nachgänger etc. finden...
Antwortento top
#5
Hallo Jörg,

danke für den Tipp! Bezieht sich deine Formel in F6 dann nicht auf die gesamte Spalte von G-AP? Das wird bei mir zumindest so angezeigt.
Ich verstehe die Formel nicht ganz.

Liebe Grüße
Antwortento top
#6
(23.09.2014, 14:43)veve schrieb: Hallo Jörg,

danke für den Tipp! Bezieht sich deine Formel in F6 dann nicht auf die gesamte Spalte von G-AP? Das wird bei mir zumindest so angezeigt.
Ich verstehe die Formel nicht ganz.

Liebe Grüße

Hi, leider verstehe ich nicht, was Du meinst..!?! ... gesamte Spalte von G-AP ... nee ich habe eine Zeile fixiert (die fünfte) und eine zum ziehen (dort sind relative Bezüge für die Zeilen) - die sechste...
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#7
Hi,

(23.09.2014, 14:43)veve schrieb: Bezieht sich deine Formel in F6 dann nicht auf die gesamte Spalte von G-AP? Das wird bei mir zumindest so angezeigt.

wieso? In der Formel
=SUMMEWENN($G$5:AP$5;$I$5;$G6:$AP6)

steht doch klar drin:
G6:AP6

In Deiner Formel für F6 ist es doch auch nur die Zeile 6:
=I6+L6+O6+R6+U6+X6+AA6+AD6+AG6+AJ6+AM6+AP6
Antwortento top
#8
(23.09.2014, 11:42)Peter schrieb: Hallo,

schau dir mal die Formel in der Formelauswertung an und du stellst fest, dass du im Index die Matrix von $G$6:$AP$13 verwendest. Bei der Zeile kommt in der Formel von G14 eine 9 heraus und hier ist das Problem: Deine Matrix umfasst lediglich 8 Zeilen.

Ja Danke! Ich habe den Bereich auf bis AP18 vergrößert und es funktioniert!
Die Formelauswertung finde ich in Excel für Mac leider nicht und auch im Internet konnte ich keine Lösung hierfür finden.

Liebe Grüße
Antwortento top
#9
(23.09.2014, 16:24)Rabe schrieb: Hi,

(23.09.2014, 14:43)veve schrieb: Bezieht sich deine Formel in F6 dann nicht auf die gesamte Spalte von G-AP? Das wird bei mir zumindest so angezeigt.

wieso? In der Formel
=SUMMEWENN($G$5:AP$5;$I$5;$G6:$AP6)

steht doch klar drin:
G6:AP6

In Deiner Formel für F6 ist es doch auch nur die Zeile 6:
=I6+L6+O6+R6+U6+X6+AA6+AD6+AG6+AJ6+AM6+AP6

Vielen Dank, aber die Formel verstehe ich nicht. Sie ist mir zu kompliziert. Wieso soll ich es kompliziert machen, wenn es auch einfach geht? So habe ich nur die Zellen addiert, die ich auch benötige. Der Bereich G6 bis AP6 wird ja gar nicht benötigt, da ich immer nur das noch verfügbare Budget benötige.
Antwortento top
#10
Hi,

(24.09.2014, 14:42)veve schrieb:
Zitat:=SUMMEWENN($G$5:AP$5;$I$5;$G6:$AP6)

In Deiner Formel für F6 ist es doch auch nur die Zeile 6:
=I6+L6+O6+R6+U6+X6+AA6+AD6+AG6+AJ6+AM6+AP6

Vielen Dank, aber die Formel verstehe ich nicht. Sie ist mir zu kompliziert. Wieso soll ich es kompliziert machen, wenn es auch einfach geht? So habe ich nur die Zellen addiert, die ich auch benötige. Der Bereich G6 bis AP6 wird ja gar nicht benötigt, da ich immer nur das noch verfügbare Budget benötige.

Du willst also lieber die ganzen Zellen zusammenklicken und wenn sich später etwas ändert, die Zellen wieder anpassen.

Ich hatte doch nur auf Deinen Satz geantwortet:
(23.09.2014, 14:43)veve schrieb: Bezieht sich deine Formel in F6 dann nicht auf die gesamte Spalte von G-AP?

das es sich sehr wohl auf den ganzen Bereich bezieht.

Du könntest ja auch einfach fragen, wenn Du die Formel nicht verstehst!
=SUMMEWENN($G$5:AP$5;$I$5;$G6:$AP6)

Das macht folgendes:
wenn im Bereich G5 bis AP5 irgendwo etwas drin steht, das gleich ist wie das, was in I5 steht, addiere die Werte, die in diesen Spalten in Zeile 6 stehen.

Du kannst auch (in Windows, in MAC auch?), wenn Du in der Zelle mit der Formel bist, links in der Bearbeitungszeile auf das Formelzeichen klicken und dann geht ein kleines Fenster auf, in dem die einzelnen Parameter drin stehen und mit Hilfe erklärt werden.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste