Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

#NV bei Index - Vergleich (wennfehler)
#1
Hallo Excel-Freunde.
 
Habe eine Wenn-Abfrage und eine Index und Vergleichs Formel genutzt:
 
=WENN(ODER(H2="Super";H7="Superplus");INDEX(F$2$F$30;VERGLEICH(A2&H2;$D$2:$D$30&$F$2:$F$30;0));"")
 
Die Berechnung passt soweit, aber wenn als Ergebnis #NV ausgegeben wird, sollte stattdessen ein leeres Feld ("") ausgeben werden.
 
Wie baue ich das in die Formel ein? z.B. mit Wennfehler?

Bei Verwendung dieser Formel werden leider auch die Felder, die ein Ergebnis (z.B. Super) lieferten, leer angezeigt:

=wennfehler(WENN(ODER(H2="Super";H7="Superplus");INDEX(F$2$F$30;VERGLEICH(A2&H2; $D$2:$D$30&$F$2:$F$30;0));"");"") 

Viele Grüße
Alexandra
Antwortento top
#2
Moin!
Da fehlen Doppelpünktchen in der Index-Matrix:
F$2:$F$30

Gruß Ralf
Gib einem Mann einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen Mann zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#3
Hola,

hier hat jemand das gleiche Problem...

http://www.herber.de/forum/messages/1535132.html

Gruß,
steve1da
Antwortento top
#4
(15.01.2017, 13:14)steve1da schrieb: Hola,

hier hat jemand das gleiche Problem...

http://www.herber.de/forum/messages/1535129.html

Gruß,
steve1da

Hallo, sicher..? Huh
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#5
Hola,

danke für den Hinweis Jockel!
Hatte das im Ipad gemacht und dann nimmt der Browser seltsamerweise den Thread darunter als Link - habs nun geändert.

Gruß,
steve1da
Antwortento top
#6
Die Formel mit Wenn-Fehler hat doch zum Erfolg geführt. Allerdings erst nach der Tastenkombination STRG+UMSCHALTEN+EINGABE.

=wennfehler(WENN(ODER(H2="Super";H7="Superplus");INDEX(F$2$:F$30;VERGLEICH(A2&H2; $D$2:$D$30&$F$2:$F$30;0));"");"") 

Gibt es eine Möglichkeit dies zu automatisieren (z.B. bei Array Formeln bei Enter immer die besagte Tastenkombination verwenden)?
Antwortento top
#7
Hola,

nimm eine der Verweis-Formel aus dem Link:

http://www.excelformeln.de/formeln.html?welcher=30

Gruß,
steve1da
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste