Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Application.WorksheetFunction.CountIf
#1
Hallo Community!

Ich versuche mich momentan an der Countif Funktion mittles VBA.

Ich habe in Tabelle 1 in den Spalten E und G Zahlen (1-5), dessen mögliche Kombinationen in Tabelle 2 in einer entsprechenden 5x5 Matrix (C3:G7) gezählt werden sollen.

Die Zählenwennfunktion lautet dazu:

=ZÄHLENWENNS(tbl_one!$E:$E;$B7;tbl_one!$G:$G;G$8)

Wie kriege ich nun diese Argumente in die
Application.WorksheetFunction.CountIf Funktion und in die 25 Felder der Matrix ?


Mit besten Grüßen
Antwortento top
#2
Hallo,

warum machst Du nicht hier:  http://office-loesung.de/p/viewtopic.php?f=166&t=730763 weiter?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Hallo,

meinst Du so etwas :


Code:
a = Application.WorksheetFunction.CountIfs(Shetts("tbl_one").Range("E:E"), , Range("B7"), Shetts("tbl_one").Range("G:G"))
Gruß Atilla
[-] Folgende(r) 1 Benutzer sagt Danke an atilla für diesen Beitrag:
  • joshua
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste