Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Trotz ungleicher Formatierung Spalten auf gleiches prüfen
#1
Hallo zusammen,

ich muss, um eine Auswertung zu erstellen, prüfen wie oft in zwei Spalten Zellen mit dem selben Wert vorhanden sind.
Ich wollte das eigentlich mit einer ZÄHLENWENNS() Funktion machen. Das Problem ist, dass ich in der einen Spalte/ dem einen Bereich einer Spalte die Formatierung: '12345 / 1 / 2        habe und in der anderen: ="12345 / 1 / 2"     . Wie kann ich also eine Addition / Zählung der Male erhalten mit der ich das Auftreten solch gleicher Nummern zählen kann?

Diese Frage habe ich auch unter http://www.ms-office-forum.net/forum/sho...ost1782944 gestellt und bisher noch keine Antwort bekommen, die es mir beantwortet hat. 

Über schnelle Antwort freue ich mich. Danke im Vorraus.
Antwortento top
#2
Hola,

bitte lade eine Beispieldatei hoch in der man die Formate erkennt.

Gruß,
steve1da
Antwortento top
#3
Hier die Datei mit den Formatierungen.


Angehängte Dateien
.xlsx   Nummern.xlsx (Größe: 44,53 KB / Downloads: 6)
Antwortento top
#4
Hola,

in Tabelle1, B2 zum runterkopieren:


Code:
=ZÄHLENWENN(Tabelle2!$A$2:$A$1912;A2)

Die Werte dann einfach summieren.


Zitat:und bisher noch keine Antwort bekommen, die es mir beantwortet hat. 

Skandal dass dir nicht innerhalb von Sekunden die Musterlösung präsentiert wurde!

Gruß,
steve1da
Antwortento top
#5
Hallo Steve,

danke für die schnelle Antwort jedoch zählt er nun wie oft der Wert in beiden Spalten zusammengenommen zu finden ist. Bsp.: 21501 / 2 / 1 ist 5 mal in Tabelle 1 Spalte A zu finden und 3 mal in Tabelle 2 Spalte 1 ist sie 3 mal zu finden. Die Funktion gibt nun für jedes Mal in Tablle 1 Spalte A eine 8 aus. Richtig wäre aber nur die 3 (für jedes der Male aus Tabelle 1 Spalte A, da ich diese dort noch mehrmals drin habe und noch nicht rausfiltern konnte).

Ich hoffe du verstehst mein noch bestehendes Problem.
LG
Antwortento top
#6
(12.01.2017, 10:10)steve1da schrieb: Hola,

in Tabelle1, B2 zum runterkopieren:


Code:
=ZÄHLENWENN(Tabelle2!$A$2:$A$1912;A2)

Die Werte dann einfach summieren.



Skandal dass dir nicht innerhalb von Sekunden die Musterlösung präsentiert wurde!

Gruß,
steve1da

Ich wollte nur das klar ist, dass das Problem nicht gelöst ist ;). Nehme es dann wieder raus, sobald es soweit ist. ^^
Danke für die Rückmeldung
Antwortento top
#7
Hola,


Zitat:jedoch zählt er nun wie oft der Wert in beiden Spalten zusammengenommen zu finden

nö. Die Funktion zählt, wie oft der Wert in Spalte A von Tabelle 2 vorkommt. Da wird nix addiert.

Von daher macht die Formel genau das was du willst.

Gruß,
steve1da
Antwortento top
#8
Hallo,


hätte ich folgende Vorschläge:

Arbeitsblatt mit dem Namen 'Tabelle2'
 ABC
1Nummer 26431286
221159 / 1 / 100
22021338 / 1 / 200
22121662 / 1 / 113
22221501 / 1 / 100
22321662 / 1 / 113
22421662 / 1 / 113
22521501 / 1 / 100
22621662 / 1 / 113

ZelleFormel
B1=SUMME(B2:B10000)
C1=SUMME(C2:C10000)
B2=WENN(ZÄHLENWENN(A2:A2;A2)=1;(ZÄHLENWENN(Tabelle1!A:A;A2)>0)*1;"")
C2=WENN(ZÄHLENWENN(A2:A2;A2)=1;ZÄHLENWENN(Tabelle1!A:A;A2);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#9
Hallo Steve,

auch mit dem Feststellen von $A$2 ändert es sich nicht. Ich bekomme immernoch eine 8, also das Vorkommen des Wertes aus der einen Spalte in beiden und nicht das Vorkommen des Wertes aus der einen Spalte in der anderen. 
Wenn du zum Beispiel nach der Nummer 21501 filterst bekommst du in Tabelle 2 Spalte A 3 Ergebnisse. Dei Formel gibt allerdings eine 8 aus. Diese ist die Anzahl für das Vorkommen der 21501 in beiden Spalten.
Antwortento top
#10
Hallo Opa,

Edgar ich habe mir die Problemstellung nicht genau angesehen, mag sein, dass alles so richtig ist, aber besteht die Möglichkeit, dass vergessen hast die Bezüge bei Zählenwenn absolut zu setzen?
Gruß Atilla
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste