Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

CSV Export immer mit Unterstrich im Text
#1
Hallo zusammen,

ich habe folgendes Problem und bin am verzweifeln:

Folgendes möchte ich als Windows CSV Datei speichern (probiert unter MAC und Windows):


Code:
<strong> Test </strong><p>blablabla<br> <strong>ACHTUNG</strong>BlaBlaBla


Leider steht in der CSV Datei dann immer folgender Inhalt:

Code:
<strong> Test_ </strong><p>blablabla<br> <strong>ACHTUNG</strong>BlaBlaBla


Bei Test wird immer ein Unterstrich gesetzt. Aber warum nur? Hat jemand eine Idee wie ich diesen Unterstrich wegbekomme?

Herzliche Grüße
Stefan
Antwortento top
#2
Hallo,

das ergibt die Auflistung der Zeichen in Deinem Text:

Arbeitsblatt mit dem Namen 'Tabelle1'
 AB
1<strong> Test </strong><p>blablabla<br> <strong>ACHTUNG</strong>BlaBlaBla 
260<
3115s
4116t
5114r
6111o
7110n
8103g
962>
1032 
1184T
12101e
13115s
14116t
1563?
1632 
1760<
1847/

ZelleFormel
A2=CODE(TEIL($A$1;ZEILE(A1);1))
B2=ZEICHEN(A2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Alles klar?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#3
Das gleiche habe ich aber auch hiermit.... 
Code:
<strong>Test</strong><p>blablabla<br> <strong>ACHTUNG</strong>BlaBlaBla
Antwortento top
#4
Hallo,

ich habe das jetzt einmal nachvollzogen, auch bei deiner letzten Variante wird das Zeichen 63 (?) nach "Test" eingefügt - warum ist mir nicht klar?! Dann habe ich des Wort "Test" durch "Versuch" ersetzt und der Unterstrich (Zeichen 63) war weg. Nacvhdem ich "Versuch" wieder durch "Test" ersetzt hatte, war er auch im ursprünglichen Code weg - seltsam!


Test

blablabla
ACHTUNGBlaBlaBla
60
<
115
s
116
t
114
r
111
o
110
n
103
g
62
>
84
T
101
e
115
s
116
t
60
<
47
/
115
s
116
t
114
r
111
o
110
n
103
g
62
>
60
<
112
p
62
>
98
b
108
l
97
a
98
b
108
l
97
a
98
b
108
l
97
a
60
<
98
b
114
r
62
>
32
 
60
<
115
s

[Bild: attachment-190.gif]
Gruß Günter
aus der Messe-, Buch-, Universitäts- und Autostadt Leipzig
Antwortento top
#5
Hallo,

es hätte gereicht, das letzte t in Test zu löschen, bei dem war etwas faul.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#6
Aber warum?

Ich habe ca. 10.000 Zeilen (alle mit verschiedenen Text -> Test war ja nur ein Beispiel)

Und überall das gleiche Problem.... 

Selbst wenn ich es als CSV ohne Formatierung aufmache, das ? oder _ lösche und es wieder als CSV schließe habe ich das Problem...
Antwortento top
#7
Hallo,

wo kommen denn die Texte her?
warum stellst Du nicht die Originaldaten vor?
Ist der Unterstrich immer an der gleichen Stelle?

Zwischen dem t von "Test" und dem Leerzeichen befindet sich ein undefinierbares Zeichen. Woher das kommt, kann man nur an den Originaldaten ersehen. Wenn es immer an der gleichen Stelle (nicht Anzahl der Zeichen vom Beginn) in dem Ausdruck auftaucht kann man es per Formel entfernen.

An Deinem Testausdruck z.B. so:


Code:
=WECHSELN(Y5;TEIL(Y5;SUCHEN("/";Y5)-3;1);"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Na weil es sich da um Informationen handelt die nicht unbedingt jeden etwas angehen Wink

Aber in meinem Beispiel ging es ja auch.

Hier ein Original. Jede Formatierung entfernt im Texteditor, dann in eine neue Tabelle eingefügt und als CSV gespeichert. Ergebnis:


Nach dem rot ein _



Code:
<strong> FisherPrice Dreirad Jolly Plus rot <br></strong><p>Fisher Price Jolly Plus 3 in 1 bietet sowohl Sicherheit als auch Komfort für Ihr Baby. Der ultimative Outdoor - Spass für die Kleinen. Verwandelt sich superschnell vom sicheren Baby-Dreirad in ein selbständiges Kleinkindfahrzeug. UV-Sonnendach, gepolsteter Sitz, Sicherheitsbügel, Elternschubstange <br> <strong>ACHTUNG Warnhinweise</strong>Keine


Das hat aber nichts mit dem t.... Ich habe das ganze auch bei dem Wort "Blue"... 

Meine Vermutung liegt eher hier, er scheint damit ein Problem zu haben:

Code:
<br></strong>



:
Antwortento top
#9
Hallo,

dann probiere es mal mit meiner Formel. Anschließend kopieren, Inhalte einfügen, Werte.

Ach ja, das < br > war in Deinem ersten Text nicht drin! Absicht oder liegt da schon der Fehler?
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#10
Nein korrekt, ob mit oder ohne Fehler ist der gleiche. Meinte auch eher das ich den Fehler hier vermute: <
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste