Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählenwenn mit Text?
#1
HalloSmile
Ich bin gerade am erstellen einer liste für meine Trainingsgruppen. (Für Spieltage)
Ich würde gerne bei "Spielerklassen" aufgelistet sehen, welcher Spieler in welcher Klasse eingetragen ist, also wenn der Spieler " Heinrich Kols" bei D-Mädchen gelistet ist sollte bei Spielerklassen DM stehen und sollte er dazu noch bei D-Knaben gelistet sein sollte dort DM,DK stehen.  Kann mir da jemand helfen? Ich habe es bis jetzt nur mit der Zählenwenns funktion versucht, doch leider kann ich dort irgendwie den bereichen keinen Namen zuordnen wenn ihr versteht was ich meine. (=ZÄHLENWENNS(A:A;A8;C:C;C8)) 
[Bild: ctsfyRL.png]

Bin ein ziemlicher Anfänger ^^
Würde mich trotzdem über Hilfe und Ideen freuen!
Grüße Justus
Antwortento top
#2
Ich habe es jetzt so versucht: 
Code:
=WENN(ZÄHLENWENNS(A1:A15;A8;C1:C15;C8);"DM";WENN(ZÄHLENWENNS(A18:A37;A8;C18:C37;C8);",DK";))

nur leider wird mir dort dann nur einer der wenn Funktionen angezeigt also nur DM und nicht noch DK...
Antwortento top
#3
Hi Justus,


Zitat:Bin ein ziemlicher Anfänger ^^

du machst gerade das, was die meisten Anfänger machen: alles, nur keine auswertbaren Listen erstellen.  32

Schau dir doch bitte mal zum Thema Listen diese Seite an: http://www.online-excel.de/excel/singsel.php?f=52

Wenn du dem Tutorial entsprechend einen Aufbau gefunden hast, gebe ich zum Auswerten vorab schon mal die Stichworte

- Pivottabelle
- INDEX/VERGLEICH
- SVERWEIS

Solltest du damit dann nicht klarkommen, melde dich erneut. Aber bitte stelle dann keine ScrShots ein, sondern Tabellenausschnitte (http://www.clever-excel-forum.de/thread-47.html) oder Beispieltabellen (http://www.clever-excel-forum.de/thread-326.html).
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Hallöchen,

wenn Du zwei Ergebnisse benötigst, kannst Du entweder über zusätzliche WENN oder über die Verknüpfung der WENN das erreichen.

Du hast ja "nur" entweder oder in Deiner Formel
=WENN(ZÄHLENWENNS(A1:A15;A8;C1:C15;C8);"DM";WENN(ZÄHLENWENNS(A18:A37;A8;C18:C37;C8);",DK";))

Besser wäre also z.B. eine Verknüpfung
=WENN(ZÄHLENWENNS(A1:A15;A8;C1:C15;C8);"DM";"") & WENN(ZÄHLENWENNS(A18:A37;A8;C18:C37;C8);",DK";"")

Schlimmstenfalls :-) erhälst Du nun

DMDK

Das könnte man noch mit WECHSELN vermeiden, im Prinzip so:
=WECHSELN(WENN(ZÄHLENWENNS(A1:A15;A8;C1:C15;C8);"DM";"") & WENN(ZÄHLENWENNS(A18:A37;A8;C18:C37;C8);",DK";"");"MD";"M;D")
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste