Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summenprodukt aber nur in den letzten 5 Jahren
#1
Hallo zusammen

Hallo Zusammen

Ich werte aktuell Daten von Unternehmen über ein bestimmtes Verhalten an der Börse aus.
Ziel ist es, zu messen wie oft eine bestimmte Firma in den letzten 5 Jahren im Datensatz vorkommt.
Dabei habe ich (vereinfacht) eine Tabelle mit 3 Spalten

1. Datum (wann die Firma eine bestimmte Aktion getätigt hat)
2. Firmen ID (eine Zahl die jede Firma eindeutig zuordnet)
3. Anzahl der kumulierten Erfahrung in den letzten 5 Jahre ---> das muss ich erstellen

Mein Datensatz umfasst 15 Jahre. Jede Firma kommt unterschiedlich oft darin vor.
Ich bräuchte also eine ZÄHLENWENNS Funktion die den Suchbereich so einschränkt, dass immer nur die letzten 5 Jahre jeweils gescreent werden und dann die Anzahl der Firma darin als Produkt ausgegeben wird.

Ich habe bereits folgende Funktion vorgeschlagen bekomme die leider nicht funktioniert:
=SUMMENPRODUKT(($A$3:$A$1658

Ich habe die Tabelle zum besseren Verständnis angehangen.
Vielen lieben dank im Voraus 
Marie


Angehängte Dateien
.xlsx   Zählenwenn nur letzte 5 Jahre_v02.xlsx (Größe: 97,5 KB / Downloads: 5)
Antwortento top
#2
Hola,

komisch, im anderen Forum sagst du dass sie funktioniert.

http://www.office-loesung.de/p/viewtopic.php?f=166&t=725759

Gruß,
steve1da
Antwortento top
#3
Hallo Marie

Dir ist hoffentlich klar dass du von mir keine Antworten mehr bekommst.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallo
Ich weiss wirklich nicht warum sich bei einer fachlichen Frage Personen persönlich angegriffen fühlen!
Ich habe die Formel eingefügt, auf den ersten Blick hat auch alles funktioniert deswegen habe ich mich dafür bedankt und erst bei Querchecks gemerkt dass es nicht klappt.
Jetzt wollte ich nicht unhöflich sein und nochmal darauf verweisen nachdem ihr mir bereits geholfen hattet und mich daher an eine andere Community gewendet.
Absolut nichts persönliches und ich freue mich über jeden der solche Foren weiterhin für die produktive Hilfe bei Fragen nutzt.


Danke
Antwortento top
#5
(01.11.2016, 14:14)marie schrieb: Hallo
Ich weiss wirklich nicht warum sich bei einer fachlichen Frage Personen persönlich angegriffen fühlen!
Ich habe die Formel eingefügt, auf den ersten Blick hat auch alles funktioniert deswegen habe ich mich dafür bedankt und erst bei Querchecks gemerkt dass es nicht klappt.
Jetzt wollte ich nicht unhöflich sein und nochmal darauf verweisen nachdem ihr mir bereits geholfen hattet und mich daher an eine andere Community gewendet.
Absolut nichts persönliches und ich freue mich über jeden der solche Foren weiterhin für die produktive Hilfe bei Fragen nutzt.


Danke

Hallo Marie,

hier fühlt sich keiner angegriffen, es geht nur um sogenanntes Crossposting (siehe hier)
Es hat niemand etwas dagegen, dass man in mehreren Foren seine Frage stellt. 
Man sollte diese jedoch untereinander verlinken, um so unnötige "Arbeit" zu verhindern.
Gruß ConnySmile
_______________________________________________________________

Die Summe der Intelligenz auf unserem Planeten ist konstant, aber die Bevölkerung wächst!
Antwortento top
#6
Hola,

ergänzend dazu weiß außer dir niemand was


Zitat:die leider nicht funktioniert:


oder


Zitat:dass es nicht klappt.


bedeutet.

Gruß,
steve1da
Antwortento top
#7
Hallöchen,
ich habe hier mal verschiedene Zählvarianten. Ich habe im Beispiel die eine ID gefiltert und die Formeln eingetragen.
Spalten C und D enthalten vorhandene Formeln und Ansätze.
In D (Ziel) wird z.B. immer über den gesamten Bereich gezählt, was junger ist als 5 Jahre vor dem Datum in Spalte A der jeweiligen Zeile. Daher die "dauerhafte" 7, ausgenommen beim letzten Datum.
In Spalte E (a) zähle ich die Einträge der letzten 5 Jahre, bezogen auf das Datum in Spalte A der jeweiligen Zeile. Spalte A enthält also das Enddatum, darauf bezogen die 5 Jahre davor.
In Spalte F (b) zähle ich die bis zur jeweiligen Zeile vorkommenden Einträge, bezogen auf ein fest vorgegebenes Datum.


Tabellenblattname: Tabelle1
ABCDEF
2DatumCompany IDBis zum Zeitpunkt gesammelte ErfahrungZIELab
311.02.1995857731711
402.04.1996857731722
528.07.1996857732733
618.05.1998857733743
702.02.1998857734754
811.10.1998857735764
909.03.2004857736114

Benutzte Formeln:
C3: =ZÄHLENWENN($B2:B$3;B3)
D3: =SUMMENPRODUKT(($B$3:$B$1658=B3)*($A$3:$A$1658>=EDATUM(A3;-60)))
E3: =SUMMENPRODUKT(($B$3:B3=B3)*($A$3:A3>=EDATUM(A3;-60)))
F3: =SUMMENPRODUKT(($B$3:B3=B3)*($A$3:A3>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A3C4: =ZÄHLENWENN($B3:B$3;B4)
D4: =SUMMENPRODUKT(($B$3:$B$1658=B4)*($A$3:$A$1658>=EDATUM(A4;-60)))
E4: =SUMMENPRODUKT(($B$3:B4=B4)*($A$3:A4>=EDATUM(A4;-60)))
F4: =SUMMENPRODUKT(($B$3:B4=B4)*($A$3:A4>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A4C5: =ZÄHLENWENN($B$3:B4;B5)
D5: =SUMMENPRODUKT(($B$3:$B$1658=B5)*($A$3:$A$1658>=EDATUM(A5;-60)))
E5: =SUMMENPRODUKT(($B$3:B5=B5)*($A$3:A5>=EDATUM(A5;-60)))
F5: =SUMMENPRODUKT(($B$3:B5=B5)*($A$3:A5>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A5C6: =ZÄHLENWENN($B$3:B5;B6)
D6: =SUMMENPRODUKT(($B$3:$B$1658=B6)*($A$3:$A$1658>=EDATUM(A6;-60)))
E6: =SUMMENPRODUKT(($B$3:B6=B6)*($A$3:A6>=EDATUM(A6;-60)))
F6: =SUMMENPRODUKT(($B$3:B6=B6)*($A$3:A6>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A6C7: =ZÄHLENWENN($B$3:B6;B7)
D7: =SUMMENPRODUKT(($B$3:$B$1658=B7)*($A$3:$A$1658>=EDATUM(A7;-60)))
E7: =SUMMENPRODUKT(($B$3:B7=B7)*($A$3:A7>=EDATUM(A7;-60)))
F7: =SUMMENPRODUKT(($B$3:B7=B7)*($A$3:A7>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A7C8: =ZÄHLENWENN($B$3:B7;B8)
D8: =SUMMENPRODUKT(($B$3:$B$1658=B8)*($A$3:$A$1658>=EDATUM(A8;-60)))
E8: =SUMMENPRODUKT(($B$3:B8=B8)*($A$3:A8>=EDATUM(A8;-60)))
F8: =SUMMENPRODUKT(($B$3:B8=B8)*($A$3:A8>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A8C9: =ZÄHLENWENN($B$3:B8;B9)
D9: =SUMMENPRODUKT(($B$3:$B$1658=B9)*($A$3:$A$1658>=EDATUM(A9;-60)))
E9: =SUMMENPRODUKT(($B$3:B9=B9)*($A$3:A9>=EDATUM(A9;-60)))
F9: =SUMMENPRODUKT(($B$3:B9=B9)*($A$3:A9>=EDATUM(DATUM(1998;5;1);-60))*($A$3:A9© schauan
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste