Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Aus Kreuztabelle einen bestimmten Wert auslesen
#1
Hallo an alle,

ich bin schon fast am verzweifeln  22 22 22

Ich habe eine Tabelle aus der ich einen wert auslesen möchte. Die Datei habe ich mit eingefügt.

Mein Problem : Ich möchte aus der Kreuztabelle einen bestimmten Wert auslesen der mir in einem anderen Tabellenblatt angezeigt wird. Ich habe mehrere Suchkriterien die unabhängig voneinander eingegeben werden und in der Kreuztabelle an verschiedenen Positionen stehen. hab schon sehr viel versucht aber leider noch nicht die richtige lösung gefunden. 


.xlsm   Beispiel Excel.xlsm (Größe: 12,77 KB / Downloads: 9)

die suchkriterien sind : Bauteil ; Orientierung und Typ

danke schonmal im voraus

grüße Lars
Antwortento top
#2
Hallo Lars

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCDEF
1OrientierungBauteilTypBreite  
2   b  
3   0,00 mSpalteZeile
4NAWII5,4134
5NAF 1I#NV3#NV
6OIWV3,28414
7SIWII3,89511
8SAT 1IV#NV5#NV
9WIWIII4,91612
10  IV#NV#NV#NV

ZelleFormel
D4=INDEX(Kreutztabelle!$1:$1048576;F4;E4)
E4=VERGLEICH(A4;Kreutztabelle!$1:$1;0)
F4=VERWEIS(42;1/(Kreutztabelle!$A$3:$A$20=B4)/(Kreutztabelle!$B$3:$B$20=C4);ZEILE(Kreutztabelle!$A$3:$A$20))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo, oder mit AGGREGAT() ..:


Code:
=WENNFEHLER(INDEX(Kreutztabelle!$C$3:$F$20;AGGREGAT(15;6;ZEILE(Kreutztabelle!$A$1:$A$18)/((Kreutztabelle!$A$3:$A$20=B4)*(Kreutztabelle!$B$3:$B$20=C4));1);VERGLEICH(A4;Kreutztabelle!$C$1:$F$1;0));"")
cu Jörg eine Rückmeldung wäre ganz reizend XL2010, XL2016
Antwortento top
#4
Arrrayformel


PHP-Code:
=INDEX(Kreutztabelle!$A$1:$F$20;MATCH(B5&C5;Kreutztabelle!$A$1:$A$20&Kreutztabelle!$B$1:$B$20;0);MATCH(A5;Kreutztabelle!$A$1:$F$1;0);1
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste