Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nicht gewollte Anführungszeichen
#1
Hallo,

ich benutze die Excel Funktion VERKETTEN, um Texte aus verschiedenen anderen Zellen zu einem Gesamttext mit HTML Steuerbefehlen zusammenzustellen, den ich dann an eine Webseite übertrage.

Beispiel: VERKETTEN(ET162;AP162;EW162). 

Die Zellen ETxxx, APxxx und EWxxx enthalten reinen Text ohne jedes Sonder- oder Anführungszeichen.

Jetzt passiert Folgendes: Manchmal (aber eben nicht immer) und ohne ersichtlichen Grund fügt Excel beim erzeugten Text ganz am Anfang und ganz am Ende (also nach EWxxx) jeweils ein Anführungszeichen hinzu. Da die Gesamtformel komplexer ist, bringt dies den gesamten HTML Code durcheinander.

Was ich herausgefunden habe:

- Entferne ich die Zelle APxxx aus der Formel, sind alle Ergebnisse wie gewünscht. Es liegt also an dieser Zelle
- Der Text in dieser Zelle ist absolut identisch mit dem Text in anderen Zellen. Keine Sonderzeichen - gar nichts.
- Die Zelle ist wie alle anderen Zellen im Format Standard formatiert.
- Eine Umformatierung z.B. auf Text nützt nichts.

Ich kann es mir höchstens so erklären, dass durch das Einfügen des Textes in die Zelle "versteckte" Formatierungen mit übertragen wurden, da ich möglicherweise nicht immer darauf geachtet habe, die Texte immer als Wert einzufügen.

Hat jemand vielleicht eine Idee, wo ich noch suchen müsste?

Danke

Max
Antwortento top
#2
Hallo,

ich kann auch nicht sagen woran es liegen kann, aber man kann mal schnell die ASCII Zeichen im Wort testen. 
Das zweite Makro listet in einer Tabelle den ASCII Code untereinander auf. Alle ASCII Zeichen von 32 bis 255. 
Der erste Code testet in einer beliebigen Zelle das Wort auf ASCII Zeichen. Alle von 32-127 sind Standard, fehlerfrei! 

Probleme könnten Zeichen machen deren Zahl über 128 liegt, evtl. auch das Leerzeichen "160" !!  Sieht optisch aus wie ein normales Space, kann aber mit dem Makro Befehl Trim nicht gelöscht werden! Deswegen gabs öfter Probleme. Die deutschen Umlaute liegen über 128, sollten aber kein Problem sein. Es gibt bei Youtube Videos aber auch Umlaute die wie deutsche Umlaute aussehen, aber aus -zwei Zeichen- bestehen. z.b. Körpersprache Stefan Verra! Man muss dreimal hinsehen um zu begreifen das es kein normales "ö" oder "ü" ist. Das verursachte mir beim auflisten von Dateien in eine Excelliste jedesmal Laufzeitfehler, weil Excel diese Zeichen als Dateiname nicht verkraften kann!! 

mfg  Gast 123

Code:
'Testet Ein Wort auf ASCII Zeichen

Sub Buchstaben_Test()
Dim Text As String
Txt = ActiveCell.Value
For i = 1 To Len(Txt)
  Zahl = Asc(Mid(Txt, i, 1))
  If Zahl > 31 And Zahl < 128 Then
     MsgBox Zahl & "  " & Mid(Txt, i, 1)
  Else
     MsgBox Zahl & "  " & Mid(Txt, i, 1) & "  kein Standard ASCII Zeichen", vbInformation
  End If
Next i
End Sub


'Bitte in seperater Tabelle auflisten !!

Sub ASCII_Code()
Dim z As Integer
For i = 32 To 127
  z = z + 1
  Cells(z, 1) = i
  Cells(z, 2) = Chr(i)
Next i
z = z + 1

For i = 128 To 255
  z = z + 1
  Cells(z, 1) = i
  Cells(z, 2) = Chr(i)
Next i
End Sub
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste