Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summewenn ODER
#1
Hallo zusammen,

ich hätte gerne folgendes in einer Formel abgebildet:

Es sollen alle Werte der Spalte B addiert werden, wenn die Spalte A den Wert xy ODER xyz ODER yz etc. enthält.
Ein Beispiel anhand der Tabelle anbei:
Bilde die Summe der Kosten im Juli von den Zeilenbeschriftungen "4110" + "4120" + "4130" etc.

Ich kann das ganze über viele hintereinander geschaltete "summewenn"-Funktionen lösen, was mir jedoch nicht sonderlich elegant vorkommt.

Gibt es eine Möglichkeit diese Funktion in einer Formel abzubilden?



Danke schon mal und viele Grüße

Alpha


Angehängte Dateien
.xlsx   Forum.xlsx (Größe: 18,41 KB / Downloads: 5)
Antwortento top
#2
Hola,


Code:
=SUMMENPRODUKT((A3:A23={4110.4120.4130})*(B3:B23))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Alpha_2412
Antwortento top
#3
Hallo Alpha,

du hast doch die Summe für jeden Monat, wenn du in Spalte A nur die gewünschten Werte dir anzeigen lässt.
Gruß ConnySmile
_______________________________________________________________

Die Summe der Intelligenz auf unserem Planeten ist konstant, aber die Bevölkerung wächst!
Antwortento top
#4
(27.10.2016, 11:36)steve1da schrieb: Hola,


Code:
=SUMMENPRODUKT((A3:A23={4110.4120.4130})*(B3:B23))

Gruß,
steve1da

Hey steve1da,

vielen Dank, funktioniert super 19

Nur eine Frage noch:
Wenn ich den Bereich in der Spalte A nicht einschränke, sondern komplett A:A überprüfen lassen will, bekomme ich #NV als Ergebnis.
(Die Werte kommen aus einer Abfrage automatisch und daher kann sich die Anzahl der zu prüfenden Zeilen auch gerne mal ändern)
Kann ich irgendwie die komplette Spalte A prüfen lassen?

Danke und Gruß
Alpha
Antwortento top
#5
Hola,

bei #NV sind die Bereiche in der Formel nicht gleich groß.
Allerdings sollte man ganze Spalten bei Summenprodukt vermeiden, das geht auf die Performance.


Code:
=SUMMENPRODUKT((A3:A1000={4110.4120.4130})*(B3:B1000))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Alpha_2412
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste