Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Werte in einem Bereich addieren wenn Bedingung erfüllt
#1
Hallo,

Ich würde gerne in Excel Tabellen von Sportligen erstellen , meine Datensätze sehen in der Form so aus:

            C                      E                                H    J
Borussia Dortmund  Hamburger SV                    3    1
Werder Bremen        SC Freiburg                       5    4 
Hoffenheim              Borussia Dortmund             1   0  usw. für den ganzen Spielplan der Bundesliga wobei H die Tore von C und J die Tore von E sind.

Wie schaffe ich es, dass Excel erkennt wenn zb. in C oder E ein Eintrag einer Mannschaft ist, anschließend die Werte in H bzw J mit den vorherigen Werten addiert werden also zb in der Form C=Dortmund X=H1, "nächsten Eintrag suchen in der Dortmund entweder C oder E ist", E=Dortmund X = H1+J3 usw? Geht das noch mit Wenn Funktionen oder müsste ich dafür schon Schleifen in VBA programmieren können?
Antwortento top
#2
Hallo Rudi,

also willst du alle Mannschaften untereinander stehen haben mit der Gesamttoranzahl ?

so ?


Tabelle1
CDEFGHI
1Mannschaft AMannschaft BTore ATore BManschaftenTore insgesamt
2
3Borussia DortmundHamburger SV31Borussia Dortmund3
4Werder BremenSC Freiburg54Werder Bremen5
5HoffenheimBorussia Dortmund10Hoffenheim1
6Hamburger SV1
7SC Freiburg4

verwendete Formeln
Zelle Formel Bereich N/A
I3:I7=SUMMEWENN($C$3:$C$5;H3;$E$3:$E$5)+SUMMEWENN($D$3:$D$5;H3;$F$3:$F$5)
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.15 einschl. 64 Bit



Oder hab ich da was missverstanden  20
Gruß,

Luffy  100

Personaltrainer - Ernährungsberater 
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste