Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

zahlen in punkten wandeln
#1
Wink 
Hallo zusammen, ich bin Newbie was Excel angeht aber ich gebe mir immer Mühe zu lernen.
Die gesuchte Formel sieht so aus , hier ist mein Vorhaben in einem Beispiel :

Bayern-Dortmund : das sind die 4 verschiedene Ausgänge (0-0,1-1,1-0,0-1) Heimmannschaft schießt 1 Tor  bekommt 2 Punkte /// schießt kein Tor . bekommt -1 Punkt, die Auswärtsmannschaft schießt 1 Tor bekommt 1 Punkt /// schießt kein Tor bekommt -1 Punkt.
Die Ergebnisse (0-0,1-1,1-0,0-1) werden in Excel händig eingetragen , ich brauche nur eine Formel die mir automatisch die Punkte berechnet da die Spielausgänge nicht immer 1-0 oder 0-1 enden ( 1-0 kann auch 3-2 sein 5-4 ...etc /// 0-1 kann auch 2-3 , 1-2...etc )
0-0 (-1 / -1 ) 
1-1 (+2 / +1 ) 
1-0 (+2 / -1 ) 
0-1 (-1 / +1 ) 


.xlsx   zahleninpunkten.xlsx (Größe: 8,87 KB / Downloads: 3)

Ich habe ein bisschen probiert mit der Funktion wennif , ich kam nicht weiter dass es viele Argumente dafür gibt, die ich nicht kenne.

Vielen Dank im Voraus für jede konstruktive Hilfe.
Antwortento top
#2
Hallo,

z.B. so:

Arbeitsblatt mit dem Namen 'Sheet1'
 ABCD
1bayern-dortmundpunktepunkte
200-1-1
31121
4102-1
501-11
6    
72221
83221
903-11
10302-1

ZelleFormel
C2=WENN(($A2="")*($B2="");"";(A2=0)*-1+(A2>0)*2)
D2=WENN(($A2="")*($B2="");"";(B2=0)*-1+(B2>0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
[-] Folgende(r) 1 Benutzer sagt Danke an BoskoBiati für diesen Beitrag:
  • dindu
Antwortento top
#3
Hallo

Eine esoterische Variante.
Code:
=MMULT({2.-1};ZÄHLENWENN(A2;{">";"="}&0))
=MMULT({1.-1};ZÄHLENWENN(B2;{">";"="}&0))
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • dindu
Antwortento top
#4
(15.07.2015, 15:36)BoskoBiati schrieb: Hallo,

z.B. so:

Arbeitsblatt mit dem Namen 'Sheet1'
 ABCD
1bayern-dortmundpunktepunkte
200-1-1
31121
4102-1
501-11
6    
72221
83221
903-11
10302-1

ZelleFormel
C2=WENN(($A2="")*($B2="");"";(A2=0)*-1+(A2>0)*2)
D2=WENN(($A2="")*($B2="");"";(B2=0)*-1+(B2>0))
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hallo BoskoBiati vielen Dank für die Hilfe, es hat funktionniert, superrrrrrrrrrrr 
Antwortento top
#5
(15.07.2015, 19:20)shift-del schrieb: Hallo

Eine esoterische Variante.
Code:
=MMULT({2.-1};ZÄHLENWENN(A2;{">";"="}&0))
=MMULT({1.-1};ZÄHLENWENN(B2;{">";"="}&0))
Hallo shift-del, vielen Dank für die Antwort, super
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste