Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summe unterschiedlicher Werte in Spalte
#1
Guten Morgen,
ich würde gerne die Summe aller Werte einer Spalte bilden, die unterschiedlich sind.
Beispiel:

2
2
2
3
4
4
5

Hier sollte als Summe (2+3+4+5) = 14 rauskommen
Wie würde die Formel aussehen?

Gruß
Jan
Antwortento top
#2
Hallo,

Annahme: deine Werte stehen in A1 bis A10.

a) ohne Hilfsspalte: =SUMMENPRODUKT(1*(VERGLEICH(""&A1:A10;""&A1:A10;)=ZEILE(1:10));A1:A10)

b) mit Hilfsspalte:

Formel in B1: =WENN(ZÄHLENWENN(A$1:A1;A1)=1;"X";"") und nach unten kopieren
Für die Berechnung der Summe: =SUMMEWENN(B1:B10;"X";A1:A10)
Gruß
Peter
Antwortento top
#3
Hallo Peter,

danke für die schnelle Antwort. Das funktioniert, aber...
In Wirklichkeit ist die Aufgabenstellung etwas komplizierter und ich schaffe es nicht, den Lösungsansatz darauf an zu passen.
Meine Tabelle sieht so aus:
     
Aus der Spalte "Value" sollen die Werte summiert werden, die eine eindeutige ID haben. In meinem Screenshot sind das die Werte, die nicht grau sind.
Die Tabelle ist dynamisch und entsteht aus einer DB-Abfrage, d.h. die Anzahl der Zeilen variiert.
Zusätzlich sollte die Summenbildung auch funktionieren, wenn ich auf die ID einen Filter setze.
Geht das?

Gruß
Jan
Antwortento top
#4
Hallo,

das ist, gegenüber dem Ausgangsposting, doch eine wesentlich erweiterte Aufgabenstellung.

Warum kommst du nicht gleich damit rüber?

Als Ansatz:

Arbeitsblatt mit dem Namen 'Tabelle1'
 ABCD
1IDValueWert70000
230X 
330  
430  
54-10000X 
64-10000  
74-10000  
84-10000  
9510000X 
10510000  
1115-15000X 
125315000X 
135420000X 
145550000X 
15560X 
16570X 

ZelleFormel
D1=SUMMENPRODUKT(TEILERGEBNIS(9;INDIREKT("B"&ZEILE(2:999)))*(C2:C999="X"))
C2=WENN(ZÄHLENWENN(A$2:A2;A2)=1;"X";"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Gruß
Peter
Antwortento top
#5
Perfekt, Danke! Aber...
Ich kann/möchte nicht mit einer Hilfsspalte arbeiten. Geht das auch ohne?
Ein weiteres Problem sehe ich, wenn ich die Summe ans Ende der Spalte schreiben möchte. Die Zelle wird dann auch mit ausgewertet.
Hinzu komm noch, dass sich die Position der Spalten ändern könnte, der Header bleibt konstant.
Kann man das Ganze auch mit benannten Bereichen abbilden?

Folgender Ansatz, bei Verwendung der Hilfsspalte hat leider nicht funktioniert.

=SUMMENPRODUKT(TEILERGEBNIS(9;Tabelle2[Value])*(Tabelle2[Spalte1]="X"))
 
Ich arbeite mit einer Tabelle und würde mich gerne auf die benannten Bereiche beziehen.

Gruß
Jan
Antwortento top
#6
(01.07.2015, 11:16)Jan schrieb: Ich kann/möchte nicht mit einer Hilfsspalte arbeiten. Geht das auch ohne?

Hallo Jan,

 ... in der Kombination von AGGREGAT() und SUMMENPRODUKT() geht das schon, benannte Bereichsnamen dedarf es da auch nicht, weil die Formel sich an Spaltenverschiebungen anpassen würde.

=SUMMENPRODUKT(AGGREGAT(15;6;(A2:A99<>A1:A99)*D2:D99;ZEILE(A1:A98)))
Gruß Werner
.. , - ...
Antwortento top
#7
Hallo Werner,

ich bedanke mich für Deine Mühe, aber leider muss ich passen.
Ich verstehe die Formel nicht und sie (scheinbar) nicht zu meinem Beispiel passt, kann ich leider keinen Bezug herstellen.

Gruß
Jan
Antwortento top
#8
(01.07.2015, 14:47)Jan schrieb: ...  die Formel nicht ... zu meinem Beispiel passt, kann ich leider keinen Bezug herstellen.

Hallo Jan,

... meine Formel ist passend für das Beispiel, welches Peter eingestellt hat.
Dein Beispiel kenne ich jetzt nicht. Aber die Anpassung  sollte kein großes Problem sein.
Gruß Werner
.. , - ...
Antwortento top
#9
Hi Jan,

Werners Formel funktioniert schon. Allerdings muss anstelle Spalte D die Spalte B angesprochen werden.

Tabelle1

ABCD
1DValueWert70000
230X
330
Formeln der Tabelle
ZelleFormel
D1=SUMMENPRODUKT(AGGREGAT(15;6;(A2:A99<>A1:A99)*B2:B99;ZEILE(A1:A98)))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8



Zitat:=SUMMENPRODUKT(AGGREGAT(15;6;(A2:A99<>A1:A99)*B2:B99;ZEILE(A1:A98)))
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#10
Hallo,

ich habe mit der Formel von Werner auch ein Problem, denn diese Forderung
Zitat:Zusätzlich sollte die Summenbildung auch funktionieren, wenn ich auf die ID einen Filter setze.
funktioniert bei mir mit dieser Formel nicht.

Aber zum einen habe ich mit Aggregat noch nicht so oft gearbeitet und zum anderen ist es mir momenan viel zu heiß um da jetzt die Ursache zu suchen.
Gruß
Peter
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste