Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

doppelte Werte bei SVERWEIS (Suchkriterium kommt mehrfach vor)
#1
Hallo zusammen,

Es geht um das Tabellenblatt "Liste-Uebersicht".
Ich habe in Spalte A mehrere Zellen mit gleichem Inhalt. Die Funktion SVERWEIS fragt die Werte in Spalte A ab und soll bestimmte Zellen aus Tabelle2 übertragen.
Jetzt habe ich das Problem, dass bei mehrfach vorkommenden Werten nicht die richtigen Zeilen übernommen werden.
Bitte am besten die Mustertabelle im Anhang anschauen. Dann seht ihr sofort was ich meine.
Ich hab die Zellen, die falsch sind , gelb markiert. Dort müsste "Braun02" stehen anstatt "Braun01". vgl. Blatt Tabelle2.
Es wäre toll, wenn jemand ne Lösung hat. Trotz Recherche komme ich nicht auf die Lösung. Huh


Angehängte Dateien
.xlsx   doppelte_Werte_bei_SVERWEIS.xlsx (Größe: 13,39 KB / Downloads: 21)
Vielen Dank für eure Unterstützung.
Gruß
ccolucci
--
Antwortento top
#2
Hallo, warum bleibst du nicht im alten thread, das ist doch das selne Thema, oder..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#3
(26.06.2015, 15:50)Jockel schrieb: Hallo, warum bleibst du nicht im alten thread, das ist doch das selne Thema, oder..?

Hallo Jockel,
ich habe die Datei nochmal neu zusammen gestellt. Die Formel von steve1da funktioniert scheinbar nicht. Außerdem hat das bisher nicht mein Problem mit den gelb markierten Zellen gelöst. Liegt wohl auch daran, dass ich mir mit dem Befehl INDEX schwer tue.
Ich hatte das Gefühl, dass wir da aneinander vorbei reden.
In meiner jetzigen Datei (siehe Attachment oben) habe ich nicht mehr 2 Dateien, sondern eine einzige. Ich habe unwichtiges rausgelöscht und meine Frage besser formuliert, ´- denke ich - hoffe ich. Blush Huh
Auch das Thema an sich ist nun besser formuliert. Oder? Ich wäre einverstanden, wenn der andere Thread gelöscht wird, aber dieser hier bestehen bleibt.

Ergänzung zum obigen Thema:
Ein lieber Leser und Excel-Kenner hat mir geholfen und folgenden Code genannt.
Allerdings steht bei mir dann eine "0" in der Zelle 'Liste-Uebersicht!B2' wenn ich die Formel in B2 (im Tabellenblatt Liste-Uebersicht) einfüge. Wo und wie muss ich die Formel einfügen, damit es funktioniert? STRG+SHIFT+ENTER ist mir bekannt.
Wenn ihr meine Datei öffnet, seht ihr sofort was ich meine.
Code:
{=WENNFEHLER(INDEX($B$2:$B$8;KKLEINSTE(WENN($A$2:$A$8=$A$2;ZEILE($1:$7));ZEILE(A1)));"")}
Vielen Dank für eure Unterstützung.
Gruß
ccolucci
--
Antwortento top
#4
Hallo, du musst eindeutige Kriterien schaffen, hier habe ich das mit einer Hilfsspalte getan..:

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCDEFGHIJK
1Liste-NummerGegenstandSpalte3BesonderheitKategorie Datum
210 55 666Putzeimer Haushaltabcabc01. Jun 10 55 6661
311 22 333Koffer Braun01Reisenabcabc02. Jun 11 22 3331
411 22 333Koffer Braun02Reisenabcabc03. Jun 11 22 3332
533 55 876Anzug Arbeitabcabc04. Jun 33 55 8761
633 57 999Reisepass PassReisenabcabc05. Jun 33 57 9991
755 66 999Schere Braun01Haushaltabcabc06. Jun 55 66 9991
855 66 999Schere Braun02Haushaltabcabc07. Jun 55 66 9992

ZelleFormel
K2=A2&ZÄHLENWENN($A$2:A2;A2)
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

dann geht's ganz einfach (auch ohne Matrixformel)..:

Arbeitsblatt mit dem Namen 'Liste-Uebersicht (2)'
ABCD
1Liste-NummerGegenstandBesonderheitKategorie
210 55 666Putzeimer0Haushalt
311 22 333KofferBraun01Reisen
411 22 333KofferBraun02Reisen
533 55 876Anzug0Arbeit
633 57 999ReisepassPassReisen
755 66 999SchereBraun01Haushalt
855 66 999SchereBraun02Haushalt
900 00 000

ZelleFormel
B2=WENNFEHLER(INDEX(Tabelle2!$A$2:$K$8;VERGLEICH($A2&ZÄHLENWENN($A$2:$A2;$A2);Tabelle2!$K$2:$K$8;0);VERGLEICH(B$1;Tabelle2!$1:$1;0));"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#5
(26.06.2015, 16:13)Jockel schrieb: Hallo, du musst eindeutige Kriterien schaffen, hier habe ich das mit einer Hilfsspalte getan..:
dann geht's ganz einfach (auch ohne Matrixformel)..:

Wahnsinn!!!! Echt top, Jockel! Vielen vielen Dank!!! Habe es schon ausprobiert und es funktioniert!!!

Nun hätte ich trotzdem noch einen Wunsch:
Wie kann ich die Spalte Tabelle2!$D verwenden , um solch eindeutige Kriterien zu schaffen??
Du siehst/ Ihr seht, es gibt dort öfters LEERE Zellen und wenn ein Eintrag ist, dann unterscheidet er sich oft nur geringfügig: z.B. Braun01 bzw. Braun02. (Außerdem können Braun01 und Braun02 öfters vorkommen, haben dann aber eine andere Nummer in Spalte A!) 
Kurz gesagt: geht es auch ohne zusätzliche Hilfsspalte?
Die Spalten von Tabelle2 sind nicht veränderbar, da Tabelle2 einen Blattschutz hat, welchen ich nicht aufheben kann und nicht darf.
Vielen Dank für eure Unterstützung.
Gruß
ccolucci
--
Antwortento top
#6
Ich habe nun versucht, die Spalte D (Tabelle2!$D) als "Hilfsspalte" zu verwenden, da sich nur in Spalte D (Tabelle2!$D) die Werte unterscheiden.
(Eine Hilfsspalte hinzufügen oder Abändern kann ich die Ursprungstabelle (Tabelle2), aus der ausgelesen wird, - wie oben erwähnt - leider nicht.
Kennt jemand eine Lösung?
Vielen Dank für eure Unterstützung.
Gruß
ccolucci
--
Antwortento top
#7
Hallo,

die Formel von Steve funktioniert doch:


.xlsx   doppelte_Werte_bei_SVERWEIS.xlsx (Größe: 13,66 KB / Downloads: 61)
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
(29.06.2015, 14:50)BoskoBiati schrieb: Hallo,

die Formel von Steve funktioniert doch:

Seltsam, die Formel funktioniert nun plötzlich. Obwohl ich STRG+SHIFT+ENTER eingegeben hatte.
Danke für den Hinweis, BoskoBiati!!!

Echt top, steve1da, VIELEN VIELEN DANK!!!!
Vielen Dank für eure Unterstützung.
Gruß
ccolucci
--
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste