Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summieren "solange" ?
#1
tag,

ich hätte folgendes Problem, in einer Spalte habe ich Zahlen/Werte stehen sowie ne Variable "X", nun möchte ich dass X die Summe der Werte bis zum nächsten X darstellt. Hoffe das macht Sinn. Das einzige was mir jetzt so in den Sinn gekommen wäre, ist ein "do while loop" via VBA ... ich möchte Makros aber in meinem sheet so weit es geht vermeiden!

Hier noch mals eine vereinfachte graphische Darstellung des Problems:

[Spalte A]
[X]
[1]
[1]
[2]
[X]
[3]
...etc

X sollte dabei immer die Summe der darunter liegenden Werte sein, zu beachten ist, dass die Anzahl der Werte sich erhöhen/veringern kann, deswegen wäre ne Funktion wo X die "Summe bis zum nächsten X" cool.

Hoffe ich hab das halbwegs verständlich geschrieben ^^

lg
Chris
Antwortento top
#2
Hallo Chris,

ich bin mal gespannt, was unsere Formelmenschen daraus machen.
Ich persönlich könnte das nur mit VBA
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#3
Hallo

Ein Vorschlag mit Hilfsspalten.
 ABCD
1    
2xWAHR14
31FALSCH1 
41FALSCH1 
52FALSCH1 
6xWAHR23
73FALSCH2 

ZelleFormel
B2=(A2="x")
C2=WENN(B2;SUMME(MAX(C1:C1);1);C1)
D2=WENN(B2;SUMMEWENN($C$2:$C$7;C2;$A$2:$A$7);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#4
Hallo Peter,

die Formelmenschen können das nur mit einer Hilfsspalte, da Excel keine Möglichkeit bietet, per Formel herauszufinden, wo eine Formel steht.
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
(18.06.2015, 16:26)shift-del schrieb: Hallo

Ein Vorschlag mit Hilfsspalten.
 ABCD
1    
2xWAHR14
31FALSCH1 
41FALSCH1 
52FALSCH1 
6xWAHR23
73FALSCH2 

ZelleFormel
B2=(A2="x")
C2=WENN(B2;SUMME(MAX(C1:C1);1);C1)
D2=WENN(B2;SUMMEWENN($C$2:$C$7;C2;$A$2:$A$7);"")
Diese Tabelle wurde mit Tab2Html (v2.4.1) erstellt. ©Gerd alias Bamberg

Hallo Detlef, soll die MAX() Formel so..? Wenn ich die nach unten ziehe, ändert sich alles in z.B. in 

=WENN(B6;SUMME(MAX(C5:C5);1);C5) da würde doch =WENN(B2;SUMME(C1;1);C1) reichen, oder =WENN(B2;C1+1;C1)

oder sehe ich was falsch..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#6
Hallo Jörg

Du siehst es richtig.
Da habe ich mich ein wenig verformelt.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
(18.06.2015, 16:28)BoskoBiati schrieb: Hallo Peter,

die Formelmenschen können das nur mit einer Hilfsspalte, da Excel keine Möglichkeit bietet, per Formel herauszufinden, wo eine Formel steht.


Hallo Edgar,

der Formelunkundige bedankt sich für die Erklärung.  Sie leuchtet mir auch problemlos ein  05
Mal sehen, ob ich das mit den Formeln auch noch hinkriege, in diesem, meinen zweiten Leben.
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#8
Hallo zusammen,

ein Ansatz wäre auch der VERGLEICH - hier mal nur der erste Gedanke, m das nächste X zu finden. Voraussetzung wäre auch ein x am Ende - sonst gibt es, wie hier, #NV
Arbeitsblatt mit dem Namen 'Tabelle2'
 BC
1x4
213
322
431
5X3
642
751
8X#NV
96#NV
107#NV

ZelleFormel
C1=VERGLEICH("X";B2:$B$10;0)
C2=VERGLEICH("X";B3:$B$10;0)
C3=VERGLEICH("X";B4:$B$10;0)
C4=VERGLEICH("X";B5:$B$10;0)
C5=VERGLEICH("X";B6:$B$10;0)
C6=VERGLEICH("X";B7:$B$10;0)
C7=VERGLEICH("X";B8:$B$10;0)
C8=VERGLEICH("X";B9:$B$10;0)
C9=VERGLEICH("X";B10:$B$10;0)
C10=VERGLEICH("X";B$10:$B11;0)
Diese Tabelle wurde mit Tab2Html (v2.5.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste