Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

eigentlich einfache Formel
#1
Moin zusammen,

ich habe mir in B2 eine Formel gebastelt:

=WENN(ODER(A2=Max);Mustermann;WENN(ODER(A2=Tom);Müller;WENN(ODER(A2=Susi);Schmist;WENN(ODER(A2=Knut);Mahlzahn;WENN(ODER(A2=Klaus);123456;WENN(ODER(A2=Rene);Losser;WENN(ODER(A2=Nils);12334456)))))))

die soll wenn ich in  a2 Max reinschreibe soll in B2 Mustermann stehen und wenn ich Tom reinschreibe soll in B2 Müller stehen und wenn ich Klaus reinschreibe soll 123456 in B2 stehen. Aber genau das tut diese Formel nicht und ich weiß nicht warum. 22 22 22

Bitte helft mir auf die Sprünge.

Danke Hagen
Antwortento top
#2
Hallo Hagen,

ich würde dieses WENN-Konstrukt gar nicht benutzen. Wie wär's damit?

Tabelle2

ABCDEF
1MaxMustermannMaxMustermann
2KnutMahlzahnTomMüller
3TomMüllerKnutMahlzahn
4
Formeln der Tabelle
ZelleFormel
B1=WENNFEHLER(SVERWEIS(A1;$E$1:$F$3;2;0);"")
B2=WENNFEHLER(SVERWEIS(A2;$E$1:$F$3;2;0);"")
B3=WENNFEHLER(SVERWEIS(A3;$E$1:$F$3;2;0);"")
B4=WENNFEHLER(SVERWEIS(A4;$E$1:$F$3;2;0);"")

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Vielen Dank, aber es soll sich ja alles auf ein Zelle beziehen. Mit Zahlen funktioniert es prächtig aber mit Buchstaben nicht und das ist mein Problem.

z.b.

 =WENN(ODER(C34=0);0;WENN(ODER(C34=1);5.5;WENN(ODER(C34=2);8;WENN(ODER(C34=3);10.5;WENN(ODER(C34=4);13;WENN(ODER(C34=5);15.5;WENN(ODER(C34=6);18)))))))

Gruß Hagen
Antwortento top
#4
Hi
und wenn der Vorname mehrfach vorkommt? Oder sehe ich da was falsch an dem Lösungsvorschlag?
Mit freundlichen Grüßen  :)
Michael
Antwortento top
#5
Hi,

dann versuch doch mal die Namen in "" einzusetzen
Mit freundlichen Grüßen  :)
Michael
Antwortento top
#6
Vielen Dank, aber es soll sich ja alles auf ein Zelle beziehen. Mit Zahlen funktioniert es prächtig aber mit Buchstaben nicht und das ist mein Problem.

z.b.

 =WENN(ODER(C34=0);0;WENN(ODER(C34=1);5.5;WENN(ODER(C34=2);8;WENN(ODER(C34=3);10.5;WENN(ODER(C34=4);13;WENN(ODER(C34=5);15.5;WENN(ODER(C34=6);18)))))))

Gruß Hagen
Antwortento top
#7
Hi Hagen,

bei meinem Vorschlag musst du halt die Suchzelle absolutieren (Dollarzeichen)


Code:
=WENNFEHLER(SVERWEIS($A$1;$E$1:$F$6;2;0);"")
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#8
(27.04.2015, 17:36)Zwergel schrieb: Hi,

dann versuch doch mal die Namen in "" einzusetzen

das geht irgendwie auch nicht 22
Antwortento top
#9
(27.04.2015, 17:49)WillWissen schrieb: Hi Hagen,

bei meinem Vorschlag musst du halt die Suchzelle absolutieren (Dollarzeichen)



Code:
=WENNFEHLER(SVERWEIS($A$1;$E$1:$F$6;2;0);"")

Moin, bei Deiner Formel blicke ich garnicht durch. Ich bin eben doch ein Anfänger.

Gruß Hagen
Antwortento top
#10
Hallo,

die ODER sind so überflüssig wie ein Kropf!!!!
Texte sind in "" zu setzen, ansonsten sind es für Excel Namen, die erst einmal festgelegt werden müssen!

Max ist für Excel eine Funktion!

Und eine Aneinanderreihung von WENN, noch dazu falsch, ist keine Formel!




Code:
=WENN(A2="Max";"Mustermann";WENN(A2="Tom";"Müller";WENN(A2="Susi";"Schmist";WENN(A2="Knut";"Mahlzahn";WENN(A2="Klaus");123456;WENN(A2="Rene");"Losser";WENN(A2="Nils");12334456))))));"")
=wennfehler(Verweis(A2;{"Klaus";"Knut";"Max";"Nils";"Rene";"Susi";"Tom"};{123456;"Mahlzahn";"Mustermann";12334456;"Losser";"Schmist";"Müller"});"")


Nachtrag: Wenn Du Anfänger bist, wäre es sinnvoll, sich mit den Grundlagen von Excel auseinanderzusetzen. Englisch lernt man ja auch nicht dadurch, dass man ein Englischbuch im Schaufenster ansieht!

Das ist sehr hilfreich:   http://online-excel.de/
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste