Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Verschachtelte WENN mit UND und ODER
#1
Hallo zusammen,

ich habe heute folgendes Problem mit einer Excel Formel.
Mein Ziel ist es, dass wenn ein Flugschüler Gleich oder mehr als die nötigen FLUG- und FORTBILDUNGSSTUNDEN hat, das Wort "Gültig" erscheint; oder wenn ein Flugschüler in einen der Kategorien (FLUG oder FORTBILDUNGSSTUNDEN) gleich oder mehr und ein der anderen weniger hat, das Wort "Freigestellt" erscheint; oder wenn ein Flugschüler in beiden Kategorien (FLUG oder FORTBILDUNGSSTUNDEN) unter dem nötigen Wert ist, das Wort "Abgelaufen" erscheint.

Außerdem sollten sich die FLUG- und FORTBILDUNGSSTUNDEN je nach der Fluglizenz und deren Stunden-Voraussetzungen richten (Lizenz A,B,C, oder D)

Ich würde mich sehr über eine Antwort oder Hilfe freuen!  19

Hier noch ein Bild der Formel bis jetzt als Anhang


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

ein Bild macht wenig Sinn - zumal man nichtmal Zeilen- oder Spaltenbeschriftungen sieht.

Gruß,
steve1da
Antwortento top
#3
Hallo,

entschuldigung, habe vergessen die Zeilen und Spalten mit zu fotografieren. Aber an dem 1. "A" unter "Lizenzart" ist D17.
Vielleicht hilft das als Orientierung Undecided

Grüße,
Constantin
Antwortento top
#4
Hola,

anders formuliert: eine Beispieldatei wäre hilfreicher Wink

Gruß,
steve1da
Antwortento top
#5
Hallo,

Steve hat recht, ein Bild ist Müll! Deine Formel hat mir aber genug Ansätze gegeben um schnell etwas zu bauen. Beachte bitte die Änderungen im Tabellenaufbau und das Format der Zellen in J und K

Tabelle1

BCDEFGHIJK
6LizenzTypKostenFortbildFlug
7AUltraleicht250mind. 1mind. 10
8B
9C
10D
11
12
13
14
15
16NachnameVornameLizenzFortbildFlugKostenZulassung
17A05250abgelaufen
18A15freigestellt
19A110gültig
Formeln der Tabelle
ZelleFormel
H17=WENNFEHLER(WAHL((E17>=SVERWEIS(D17;$G$7:$K$10;4;0))+(F17>=SVERWEIS(D17;$G$7:$K$10;5;0))+1;"abgelaufen";"freigestellt";"gültig");"")

Tabelle1

JK
7mind. 1mind. 10

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste