Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Funktion LINKS kombinieren
#1
Hallo,

ich habe längere Zeit nicht mehr ge"excelt" und bin etwas raus.
Daher möchte ich euch bitten mir einen kurzen Denkanstoß zu geben.
Wie kann ich die Funktion LINKS kombinieren mit 2 Bedingungen.
Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

Ich sag schon mal ganz vielen Dank.

Grüße
Antwortento top
#2
Hallo, eine Möglichkeit wäre..:
=WENNFEHLER(LINKS(WECHSELN(WECHSELN(A1;",";"#");" ";"#");SUCHEN("#";WECHSELN(WECHSELN(A1;",";"#");" ";"#"))-1);A1)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#3
Hallo Jockel

tausend Dank, das hätte ich nie alleine hinbekommen, funktioniert bestens.
Jetzt kann ich endlich weiterbasteln...

Danke und Grüße
Bea die erste
Antwortento top
#4
Hi,

ginge auch etwas kürzer:


Code:
=WENNFEHLER(LINKS(A1;SUCHEN("#";WECHSELN(WECHSELN(A1;" ";"#");",";"#"))-1);"")
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#5
Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe
Antwortento top
#6
(17.04.2015, 11:21)Kuwer schrieb: Hallo,

hier noch zwei weitere Möglichkeiten:

=TEIL(A1;1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)
=LINKS(A1;MIN(SUCHEN(",";A1&",");SUCHEN(" ";A1&" "))-1)

Gruß Uwe

Hi Uwe, gefällt mir sehr gut... (^_-)
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#7
Thumps_up Cool Cool
Gruß

Edgar

Meine Antworten sind freiwillig und ohne Gewähr!
Über Rückmeldungen würde ich mich freuen.
Antwortento top
#8
Hi,

(17.04.2015, 09:46)bea die erste schrieb: Es soll: 1) Text ausgelesen werden bis zum ersten Komma ODER bis zur ersten Leerzeile

ich hatte da ein Problem, in der Zelle die erste Leerzeile zu finden, das ist ja was anderes als eine Leerstelle.

Darum bin ich auf keine Formel gekommen.
Antwortento top
#9
Hallo Rabe,

ich habe mich falsch ausgedrückt - bis zur ersten Leerstelle war schon richtig.
Manchmal klappt es mit dem Denken nicht mehr so gut Sad

Danke fürs Lesen
Grüße und schönen Samstag
Bea die erste und ihr Schlauch, auf dem sie bei der Beschreibung definitiv stand...und immer noch steht...
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste