Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Spalten Vergleich Einträge müssen nebeneinander stehen
#1
Video 
Guten Tag zusammen,

ich zerbreche mir den ganzen Tag den Kopf und schaffe es nicht und hoffe Ihr könnt helfen. Ich habe zwei Suchkreterien (Kundenname; Artikelnummer)  Diese sollen in Spalten verglichen werden, und wenn diese in beiden Spalten vorhanden sind, soll eine Info kommen. Soweit ist das kein Problem nur wichtig ist das eine Info ausgegeben wird wenn beide Bedingungen nebeneinander stehen. Mit der Wenn und Vergleich Funktion schaffe ich es eine Info zu erhalten wenn diese Werte zu finden sind aber das hilft mir nicht. Ich hänge mal ein Bild an und in Rot ist markiert was wichtig ist für mich. Es wäre super wenn das Ergebnis noch in einer Zelle ausgewiesen wird

Ich hoffe ihr wisst was zu tun ist.

1000 Dank


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

http://www.excelformeln.de/formeln.html?welcher=30

die dortigen Verweis Formeln sind recht einfach anzupassen.

Gruß,
steve1da
Antwortento top
#3
Hi,

filter das Ganze doch einfach.

1. Filter auf den gesuchten Namen
2. Filter auf die Artikelnummer

Und links kannst du die Zeilennummer ablesen.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Das geht nicht so einfach . Er soll mir nur die Info geben wenn der Name und die Artikelnummer direkt nebeneinander stehen
Antwortento top
#5
Hast du es ausprobiert?

1. Original

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1NamenArt.-Nr.Menge
2Anton111110
3Berta222212
4Anton333314
5Gerda111116
6Willi222218
7Anton444420
8Berta555522
9
10
11GesuchtAnton
12Art.-Nr.4444
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

2. Filter in Spalte A nach Anton gesetzt

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1NamenArt.-Nr.Menge
2Anton111110
4Anton333314
7Anton444420
9
10
11GesuchtAnton
12Art.-Nr.4444
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

3. Filter in Spalte B nach Art.-Nr. gesetzt

Arbeitsblatt mit dem Namen 'Tabelle1'
ABC
1NamenArt.-Nr.Menge
7Anton444420
9
10
11GesuchtAnton
12Art.-Nr.4444
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Das war's.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#6
Hallo Danke für deine Hilfe,

ja das es so geht verstehe ich. Meine Liste ist leider etwas Komplexer. Ich möchte das automatisch eine Information kommt wenn so etwas passiert. In meiner Liste habe ich 100 Kunden die auf eine Datenbank zugreifen. Wenn die Daten eingepflegt werden soll das System erkennen das diese Ergebnisse vorliegen und mir einen Hinweis geben. Darum müsste ich mit dem Index arbeiten und der Array Funktion . Nur das bekomme ich auch nicht hin Sad
Antwortento top
#7
Hallo,

ja das mit dem Index und Array geht soweit gut wenn es in einem Arbeitsblatt steht. Wenn ich aber was verknüpfen will geht das nicht. Meine liste ist etwas komplexer als mein Beispiel
Antwortento top
#8
Hola,

„geht nicht“ ist nicht hilfreich. Was willst du verknüpfen? Warum lädst du keine Excel Beispieldatei hoch?

Gruß,
steve1da
Antwortento top
#9
Hallöchen,

ich glaube, da ist eine genaue Beschreibung des gewünschten Ergebnisses wichtig. Ich könnte mir anhand der bisherigen Beschreibung vorstellen, dass so etwas passen könnte:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1BestandEingabeVorhanden
2WilliBaldWilliBald1
3OttoKarOttoMotor0

ZelleFormel
F2=ZÄHLENWENNS($A$2:$A$3;$D$2;$B$2:$B$3;E2)
F3=ZÄHLENWENNS($A$2:$A$3;$D$2;$B$2:$B$3;E3)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste