Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Arbeitstage Zählen
#1
Hallo zusammen,

ich habe einen Excel Export, in diesem File werden Auswertungen pro Mitarbeiter pro Tag mit Datum und Uhrzeit mehrfach angeführt. Für eine Berechnung, bräuchte ich die Anzahl der gearbeiteten Tage.
Im Beispiel der Datei: Astrid hat an 2 Tagen gearbeitet und Alex an 3 Tagen
Gibt es hierzu eine Formel, die das Datum zählt und mir  sagt wie oft der Mitarbeiter gearbeitet hat?

Beste Grüße,
Luc


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,44 KB / Downloads: 9)
Antwortento top
#2
Moin

Das geht z.B. mit einer Pivot.
Im Einfüge-Dialog muss der Haken für das Datenmodell gesetzt werden.
Mitarbeiter in Zeilen, Beginn Datum/Uhrzeit in den Wertebereich und die Zusammenfassungsfunktion auf "Diskrete Anzahl" ändern.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hi,

auch mit PQ lösbar.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Zitat:Gibt es hierzu eine Formel, die das Datum zählt und mir  sagt wie oft der Mitarbeiter gearbeitet hat?
Hallo,
als Formel sollte folgende Matrix-Formel das gewünschte Ergebnis liefern:

Code:
=SUMMENPRODUKT((VERGLEICH($A$2:$A$34&GANZZAHL($B$2:$B$34);$A$2:$A$34&GANZZAHL($B$2:$B$34);0)=ZEILE($X$1:$X$33))*($A$2:$A$34=E4)*($B$2:$B$34<>""))


In E4 steht der Name,
Ganzzahl() habe ich hinzugefügt, damit unterschiedliche Anfangszeiten ignoriert werden.

Formel angepasst von hier:
http://www.excelformeln.de/formeln.html?welcher=334
Gruß Holger


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 16,07 KB / Downloads: 6)
Antwortento top
#5
Hallöchen,

oder in Anpassung einer anderen Formel und ohne Berücksichtigung eventuell unterschiedlicher Zeiten Smile

Arbeitsblatt mit dem Namen 'Tabelle1'
EF
3Arbeitstage
4Astrid2
5Alex3

ZelleFormel
F4{=SUMME(N(WENN(($A$1:$A$34=E4);VERGLEICH(WENN(($A$1:$B$34=E4);$B$1:$B$34);WENN(($A$1:$A$34=E4);$B$1:$B$34);)=ZEILE($1:$34))))}
Achtung, Matrixformel enthalten!
Die geschweiften Klammern{} werden nicht eingegeben.
Verlassen Sie den Zelleneditor mit Strg+Shift + Enter, statt Enter alleine.
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste