Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Spalten auf ähnlichkeit überprüfen
#1
Hallo liebe Community,

ich habe eine Frage bezüglich des vergleichens von Spalten. Ich habe 2 verschiedene Einordnungen von Kategorien zu Antworten in Form von Zahlen und möchte testen ob diese Einordnungen Übereinstimmen.
Also zum Beispiel:
zu Antwort 1 gab es die Einordnungen: I= 1.1 ; J= 1.1
In diesem Fall ist es einfach: =WENN(I2=J2;"Identisch";"nicht identisch")

Aber gab es auch den Fall wo eine Antwort nicht nur in eine Kategorie eingeordnet wurde, z.B.:
zu Antwort 2 gab es die Einordnungen: I= 1.1; J= 1.1 & 2.1
Ich möchte in diesem Fall immer noch ein "Identisch" angezeigt bekommen, da beide Einordnungen 1.1 enthalten. Welche Formel muss ich eingeben, damit mir "Identisch" angezeigt wird, wenn beide Einordnungen mindestens einen gleichen Wert enthalten?
LG Hansi

.
Antwortento top
#2
Hallo Hansi,

schau dir mal die Fkt. ZÄHLENWENN() an. Wenn dir das schon reicht, ist's gut, sonst solltest du eine (anonymisierte) Beispieldatei hochladen. Sie muss vom Aufbau her identisch mit deinem Original sein; ein paar händisch eingetragene Wunschergebnisse helfen beim Helfen.  https://www.clever-excel-forum.de/thread-326.html
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
ich will zum beispiel, dass in der dritten reihe nicht "nicht identisch" steht sondern "identisch", da in beiden 1.4. vorkommt.
LG und danke für deine antwort


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Hi,

wer lesen kann, ist klar im Vorteil:
Zitat:sonst solltest du eine (anonymisierte) Beispieldatei hochladen. Sie muss vom Aufbau her identisch mit deinem Original sein; ein paar händisch eingetragene Wunschergebnisse helfen beim Helfen.

War hier von einem Bildchen die Rede?
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#5
sorry, im anhang ist eine Beispieldatei.
ich möchte, dass bei den Antworten 1 & 2 in der Spalte Übereinstimmung "Identisch" angegeben wird und bei den Antworten 3 & 4 "Nicht Identisch".
LG


Angehängte Dateien
.xlsx   bsp.xlsx (Größe: 26,53 KB / Downloads: 8)
Antwortento top
#6
Hi, 

Kann deine datei gerade nicht runterladen, aber schau dir doch mal die Funktionen =suchen() oder =finden() an. Denke damit kannst du deine Zellen auswerten und dann mit einer wenn-formel drumherum dein Ergebnis anzeigen lassen. Wenn beide Spalten allerdings mehreren Kategorien zugeordnet werden, wird es komplizierter..

Gruß
Antwortento top
#7
Hallo Hansi,

passt das so?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCD
1antwortKategorierating1Kategorierating 2Übereinstimmung
211.1.1.1.identisch
321.2. & 1.4.1.2. & 1.5.identisch
433. & 2.2.1.1. & 2.1.nicht identisch
542.1.2.2.nicht identisch

ZelleFormel
D2=WENN(ODER(UND(LINKS(B2;1)="1";LINKS(C2;1)="1");UND(TEIL(B2;8;1)="1";TEIL(C2;8;1)="1")=WAHR);"identisch";"nicht identisch")
D3=WENN(ODER(UND(LINKS(B3;1)="1";LINKS(C3;1)="1");UND(TEIL(B3;8;1)="1";TEIL(C3;8;1)="1")=WAHR);"identisch";"nicht identisch")
D4=WENN(ODER(UND(LINKS(B4;1)="1";LINKS(C4;1)="1");UND(TEIL(B4;8;1)="1";TEIL(C4;8;1)="1")=WAHR);"identisch";"nicht identisch")
D5=WENN(ODER(UND(LINKS(B5;1)="1";LINKS(C5;1)="1");UND(TEIL(B5;8;1)="1";TEIL(C5;8;1)="1")=WAHR);"identisch";"nicht identisch")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#8
Hi,

habe noch einen Fehler entdeckt.

Arbeitsblatt mit dem Namen 'Tabelle1 (2)'
ABCD
1antwortKategorierating1Kategorierating 2Übereinstimmung
211.1.1.1.identisch
321.2. & 1.4.2.2. & 1.5.identisch
433.1. & 1.2.1.1. & 2.1.identisch
542.1.2.2.nicht identisch
651.2. & 2.2.2.2. & 1.3.identisch
761.3.2.1.nicht identisch
872.2 & 2.31.1 & 1.2.nicht identisch

ZelleFormel
D2=WENN(ODER(UND(UND(LÄNGE(B2)=4;LINKS(B2;1)="1";LÄNGE(C2)=4;LINKS(C2;1)="1"));UND(ODER(LINKS(B2;1)="1";TEIL(B2;8;1)="1");UND(ODER(LINKS(C2;1)="1";TEIL(C2;8;1)="1"))));"identisch";"nicht identisch")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • Hansi007
Antwortento top
#9
Vielen Dank für die Hilfe bisherSmile! @WillWissen, leider macht die Formel noch nicht ganz was sie soll. Das sieht man auch bei deinem Bsp.: bei Antwort 2 gibt sie "identisch" an, obwohl keine der Zahlen übereinstimmt und wenn bei beiden Kategorierating-Spalten zum Beispiel "3." steht , kommt  bei mir "nicht identisch" raus.
LG Hansi
Antwortento top
#10
und die Formel unterscheidet noch nicht zwischen 1.1. und 1.1.2.
LG und vielen Dank!!!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste