Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Multiplikation von nur possitven bzw. nur negativen Zahlen
#1
Hallo,

ich muss eine Tabelle erstellen, welche 2 Spalten besitzt.
Die Linke Spalte (B2:B14) enthält Zahlen von 0-5, welche als Faktor dienen.
Die Rechte Spalte enthält Zahlen von -3 - 3, diese geben die Wertung an.

Nun möchte ich als extra Zellen einmal die Summe aller possitven Wertung * Faktor haben und die Summe aller negativen Wertungen * Faktor.
Soll wie folgt aussehen:

Dateien bitte im Forum hochladen: https://www.clever-excel-forum.de/thread-326.html

Vielleicht weiss ja einer wie man am besten vorgehtSmile

Vielen Dank und Grüße


Angehängte Dateien
.xlsx   Muster.xlsx (Größe: 9,94 KB / Downloads: 6)
Antwortento top
#2
Hola,

hier mal für die Zahlen größer 0.

Code:
=SUMMENPRODUKT((B2:B6*C2:C6)*(C2:C6>0))

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • KeinExcelGuru
Antwortento top
#3
Hi,

so?

Arbeitsblatt mit dem Namen 'Tabelle2'
ABCD
1FaktorWertenegativpositiv
23-3-3030
323-2020
45-5-5050
50500
65-2-5050
70200

ZelleFormel
C2=SUMMEWENN($B$2:$B$7;"<0")*A2
D2=SUMMEWENN($B$2:$B$7;">=0")*A2
C3=SUMMEWENN($B$2:$B$7;"<0")*A3
D3=SUMMEWENN($B$2:$B$7;">=0")*A3
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
Danke Steve1da und WillWissen,

hab leider zu spät gesehen, dass man die Mappe auch hochladen kann.
Das Steve gezeigt hat, entspricht dem was ich meine. Allerdings funktioniert die Formel für die negativen Zahlen leider nicht
Antwortento top
#5
(15.04.2019, 11:11)KeinExcelGuru schrieb: ... Allerdings funktioniert die Formel für die negativen Zahlen leider nicht...

Hallo, das ist nicht dein Ernst, oder?
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#6
C13[:F13]: =SUMMENPRODUKT($B3:$B12*C3:C12*(C3:C12>0))
C14[:F14]: =SUMMENPRODUKT($B3:$B12*C3:C12*(C3:C12<0))
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste