Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Anwendungs- oder objektorientierter Fehler - und geht doch
#1
Ha((o

Habe einen komischen Fehler. Ich lege Dokumente über eine UserForm in einen Ordner ab und lege dafür noch eine neue Zeile in einer Tabelle ab, mit der ich die Datei verlinke. Bei jedem Ablegen bekomme ich immer an der gleichen Stelle den Fehler "Laufzeitfehler '1004': Anwendungs- oder objekdefinierte Fehler" (außer beim allerersten Mal). Aber jetzt kommt's. Wenn ich dann mit F5 oder F8 das Programm "weiterbewege", läuft es ohne Probleme durch bis zum Schluß und macht was es soll.

Hier die Stelle, wo der Fehler auftritt:
Code:
s(1) = Rows(2).Find(What:="Kontobezeichnung", LookAt:=xlWhole, MatchCase:=True).Column
Cells(z1, s(1)).Activate
    With ActiveCell.Validation        
        .Delete
       .Add Type:=xlValidateList, AlertStyle:=xlValidAlertStop, Operator:= _
       xlBetween, Formula1:="=indirect(""Liste_Konten[Konten]"")"
       .IgnoreBlank = True
       .InCellDropdown = True
       .InputTitle = "Finanzkonten"
       .ErrorTitle = "Falsche Eingabe"
       .InputMessage = "Bitte Finanzkonto aus der vorgegebenen Liste wählen"
       .ErrorMessage = "Bitte nur ein Konto aus der Vorschlagsliste auswählen"
       .ShowInput = True
       .ShowError = True
   End With
Der Fehler tritt bei ".Add Type" auf.

Jetzt schon danke.
Grüße
Nyn007
Antwortento top
#2
.Add Type:=xlValidateList, , , "=indirect(""Liste_Konten[Konten]"")"

könnte evtl. Probleme machen. Mal ins Blaue geraten:

Names.Add "ListeKonten", "=INDIRECT(""Liste_Konten[Konten]"")"
.Add Type:=xlValidateList, , , "=ListeKonten"
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste