Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis bei nicht augeschriebenen Wörter
#1
Hallo zusammen,

ich habe folgendes Problem:

Ich möchte eigentlich ein Sverweis benutzen der aber nicht das komplette Wort prüft sondern nur Bestandteile.
Wenn beispielsweise im Wort ABC vorkommt soll in einer anderen spalte  Produktgruppe test1 zugeordnet werden unabhängig was links oder rechts von der Eingabe steht. 
Also beispielsweise soll auch ABCasdf oder xx3ABCadsf oder ABC323 usw test 1 richtig zugeordnet werden(Hauptsache ABC kommt vor). 
Super wäre wenn im leeren Eingabefeld kein Fehler angezeigt wird. Außerdem handelt es sich um eine fortlaufende Tabelle


xxABCxxx              test1
EFX                      test2
XRX                      test424
X3E                       hallo


Hier ist der Befehl wie ich ihn angwendet habe: Das dick hervorgehobene sollen Platzhalter sein... funktioniert aber nicht richtig. 

=SVERWEIS("*"&A17&"*";A5:B8;2;FALSCH)

Kann mir jemand helfen?

Danke im voraus Smile
Antwortento top
#2
(12.04.2019, 20:39)gioR schrieb: funktioniert aber nicht richtig. 
Und das bedeutet konkret?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo
die Formel sollte einwandfrei funktionieren. siehe Anhang

Zitat:Super wäre wenn im leeren Eingabefeld kein Fehler angezeigt wird.

Das kann irgendwie auch nicht sein, da das Suchkriterium ohne Inhalt in A17 "**" ist, was bedeutet das SVerweis() die oberst Zelle liefert die nicht leer ist (B5)
Überprüfe noch mal deine Formel und Zellinhalt ob das wirklich so da drin steht.
Dann bitte gerne mit einer Beispiel-Datei
Gruß Holger


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 15,2 KB / Downloads: 2)
Antwortento top
#4
Hallo,

das ging ja sehr fix ! Danke

Ich habe mal ein Screenshot gemacht mit Deiner Datei was das Problem ist.. Wenn ich im Eingabefenster noch etwas an EFX anhänge geht es nicht.. Und das soll gehen Undecided

Danke und Grüße!


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#5
Hallo
der SVerweis benötigt einen konkreten Suchbegriff, der kann dann in der Suchspalte (durch die *..*)  überall stehen.
Wenn es die linken drei Buchstaben sind die gesucht werden sollen dann begrenze die Zeichen mit links().

Max drei Zeichen von Links
Keine Anzeige wenn F17 leer ist.
Fehlermeldung wenn der Suchbegriff nicht vorhanden ist

=WENNFEHLER(WENN(A17<>"";SVERWEIS("*"&LINKS(A17;3)&"*";A5:B8;2;FALSCH);"");"nicht gefunden")

Gruß Holger
[-] Folgende(r) 1 Benutzer sagt Danke an echo für diesen Beitrag:
  • gioR
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste