Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Wenndann datum
#1
Moin , falls ich irgendwelche Gesprächsregeln nicht beachtet oder eingehalten haben sollte, bitte ich schon mal um Entschuldigung..

Mein Problem lautet wie folgt:

Wenn ich in Spalte C einen Eintrag mache, dann möchte ich das in Spalte A . in der selben Zeile das Datum vom Tag des Eintrags erscheint .. das klappt auch, indem ich folgende Formel verwende WENN(C2;JETZT();"")

ABER jetzt möchte ich, dass das Datum nicht nur dann in Spalte A auftaucht, wenn ich etwas in Spalte C eintrage , sondern das Datum soll auch kommen, wenn ich etwas in Spalte D eintrage.

ich dachte das Problem löse ich, in dem ich einfach WENN(C2;JETZT();"");WENN(D2;JETZT();"") anwende, also quasi dasselbe einfach mit "D" statt "C" hinten dranhänge .. dann bekomme ich aber nur "#WERT" Fehlercode ...

Kann mir da jemand helfen? Ich hoffe es ist einigermaßen verständlich.

Dankeschön
Antwortento top
#2
Hi Peppe,

so:

=WENN(ODER(C2<>"";D2<>"");JETZT();"")

LG
Alexandra
Antwortento top
#3
Moin!
=WENN(ANZAHL2(C2:D2);JETZT();"")
"Richtiger" wäre allerdings
=WENN(ANZAHL2(C2:D2)>0;JETZT();"")
Da Excel alle Zahlen >0 als WAHR wertet, geht auch die erste Formel.

Beachte alledings, dass JETZT() "flüchtig" ist, sich also bei jeder Änderung im Tabellenblatt aktualisiert.

Was Du wohl wirklich meinst, ist VBA.
Dazu kannst Du mal nach Zeitstempel VBA suchen.

Gruß Ralf
Gib einem man einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen man zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#4
15 15 15 15

Juhu, hat geklappt !!! Vielen lieben Dank Alexandra 100   !! Und auch dir Ralf , aber Alexandras Lösung funktioniert perfektSmile
Antwortento top
#5
Lies bitte unbedingt meinen Beitrag!
Gib einem man einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen man zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#6
Och menno...
Zu langsam.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#7
(12.04.2019, 17:00)RPP63 schrieb: Moin!
=WENN(ANZAHL2(C2:D2);JETZT();"")
"Richtiger" wäre allerdings
=WENN(ANZAHL2(C2:D2)>0;JETZT();"")
Da Excel alle Zahlen >0 als WAHR wertet, geht auch die erste Formel.

Beachte alledings, dass JETZT() "flüchtig" ist, sich also bei jeder Änderung im Tabellenblatt aktualisiert.

Was Du wohl wirklich meinst, ist VBA.
Dazu kannst Du mal nach Zeitstempel VBA suchen.

Gruß Ralf

Das heisst, wenn ich morgen etwas neues eintrage, dann ändert sich auch das Datum von den Einträgen, die heute eingetragen wurden? Das wäre ja doof.!!
Antwortento top
#8
Hi Peppe,


Ist aber so, was du willst ist ein ZeitDatum Stempel und das geht nur per VBA!

LG
Alexandra
Antwortento top
#9
@Alexandra:
Es gibt tatsächlich auch eine Formel, allerdings nur, wenn die Iterationen auf 1 umgestellt werden, was ich einem Anfänger keinesfalls empfehlen würde.
Dennoch mal der Link:
http://www.excelformeln.de/formeln.html?welcher=415
Gib einem man einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen man zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
Antwortento top
#10
Hi Peppe,

falls für dich VBA in Frage kommt, dann so!

LG
Alexandra


Angehängte Dateien
.xlsm   Datum in A bei Änderung in Spalte C oder D.xlsm (Größe: 14,23 KB / Downloads: 5)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste