Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel für Summenprodukt funktioniert nicht
#1
Hi Leute, habe eine  Formel, die mir ein Summenprodukt auswirft, mit mehreren Kriterien. Innerhalb einer Datei von Tabellenblatt zu Tabellenblatt funktioniert die wunderbar.

Jetzt hab ich zwei Daten verknüpft, so das die Zahlen aus einer anderen Datei kommen. Funktioniert ein Stück weit, bzw. er nimmt den Monat (z.B Januar =1) nicht. er zeigt mir nur die Gesamtsumme der Daten. ich möchte aber nur die Daten innerhalb eines jeweiligen Monats.

Hier meine Arrayformel:

=SUMMENPRODUKT((MONAT('N:\Fahrzeugmangement\Fahrzeug-Treibstoffe\Bulk Data\[Bulk Data Jan-März 2019.xlsx]Bulk DATA 01_032019'!$F$2:$F$5000=1)*('N:\Fahrzeugmangement\Fahrzeug-Treibstoffe\Bulk Data\[Bulk Data Jan-März 2019.xlsx]Bulk DATA 01_032019'!$Q$2:$Q$5000=Verbrauch2019!A32)*('N:\Fahrzeugmangement\Fahrzeug-Treibstoffe\Bulk Data\[Bulk Data Jan-März 2019.xlsx]Bulk DATA 01_032019'!$T$2:$T$5000={30.32.33})*('N:\Fahrzeugmangement\Fahrzeug-Treibstoffe\Bulk Data\[Bulk Data Jan-März 2019.xlsx]Bulk DATA 01_032019'!$U$2:$U$5000)))

Weiss jemand warum er den Monat nicht abgrenzt????

Hilfe wäre super, vielen Dank schon mal.

Grüße Rayker
Antwortento top
#2
Hola,

Weiss jemand warum er den Monat nicht abgrenzt????

Ja. Du prüfst den Monat innerhalb der Abfrage
Code:
=SUMMENPRODUKT((MONAT('N:\Fahrzeugmangement\Fahrzeug-Treibstoffe\Bulk Data\[Bulk Data Jan-März 2019.xlsx]Bulk DATA 01_032019'!$F$2:$F$5000)=1)*(......))

Wäre korrekt. Außerdem solltest du noch eine Abfrage einbauen, dass F2:F5000<>"" ist, weil leere Zellen in diesem Bereich als 1 angesehen werden und somit den Januar verfälschen können.

Gruß,
steve1da
Antwortento top
#3
Vielen Dank!!!!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste