Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Nächsten Wert finden
#1
Hallo,


Mit Hilfe der folgenden Formel suche ich mir immer den nächsten Wert aus der Spalte N.

1. Wert aus der Liste steht in A7
=WENNFEHLER(INDEX($N$2:$N$21;AGGREGAT(15;6;ZEILE($N$2:$N$21)-1/(ZÄHLENWENN($A$6:A6;$N$2:$N$21)=0);1));"")

2. Wert  aus der Liste steht in A24
=WENNFEHLER(INDEX($N$2:$N$21;AGGREGAT(15;6;ZEILE($N$2:$N$21)-1/($N$2:$N$21<>"")/(ZÄHLENWENN($A$7:A7;$N$2:$N$21)=0);1));"")

Insgesamt gibt es in der Liste maximal 5 verschiedene Wert die zu übertragen sind.

Hamburg
Berlin
Köln
Düsseldorf
Frankfurt

Diese können allerdings auch so untereinander stehen:

Hamburg
Hamburg
Berlin
Berlin
Berlin
Köln
Düsseldorf
Frankfurt


Oder
Hamburg
Hamburg
Berlin
Berlin

Die ersten beiden Möglichkeiten kriege ich abgedeckt.
Nun fehlt mir allerdings die dritte Möglichkeit.
Wenn nicht alle Städtenamen in Spalte N stehen, kenne ich keine Möglichkeit den Wert aufzulisten, der nicht vorhanden ist...


Über Tipps wäre ich sehr dankbar.
Antwortento top
#2
Hallo, ist das die Fortsetzung von hier...? 

--> https://www.clever-excel-forum.de/thread-19936.html

Kannst du nicht mal bitte (d)eine (Beispiel)Datei posten..?
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#3
Hallo,

im gewissen Maße ist es eine Fortsetzung.

Sehr gut erkannt.

Anbei mal eine Beispieldatei.
Ab Zeile 92 kann ignoriert werden.
Danke für deine Antwort


Angehängte Dateien
.xlsx   Wert anzeigen.xlsx (Größe: 24,3 KB / Downloads: 3)
Antwortento top
#4
Hallo deschroe,

wenn ich Dein Anliegen richtig interpretiert habe, dann wäre eine Voraussetzung für eine korrekte Auswertung, dass Du in Tabelle3 die Städtenamen wie in Spalte N Deiner Datentabellen schreibst. So hast Du in in Tabelle3!A1 ein zusätzliches Leerzeichen an "Hamburg" zu stehen.

Eine zweite Voraussetzung wäre, dass die 5 Städtenamen aus Tabelle 3 nicht in den Zwischenzeilen der Auswertungstabellen vorkommen können.

Wenn das gewährleistet ist, dann folgende Formel in A7 von z.B. Fall2:


Code:
=WENNFEHLER(INDEX(N:N;AGGREGAT(15;6;ZEILE(N$2:N$21)/($N$2:$N$21<>"")/(ZÄHLENWENN(A$1:A6;N$2:N$21)=0);1));
WENNFEHLER(INDEX(Tabelle3!A:A;AGGREGAT(15;6;ZEILE(Tabelle3!A$1:A$5)/(ZÄHLENWENN(A$1:A6;Tabelle3!A$1:A$5)=0);1));""))

und diese Formel in die weiteren 4 Zielzellen einsetzen. und Du erhältst dann auch die beide restlichen Städtenamen.
Gruß Werner
.. , - ...
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste