Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Makros erstellen, um Werte in andere Register zu sortieren
#1
Hallo,

Ich muss eine lange Liste an Daten in verschiedene "Register" in eine Excel-Datei sortieren.
Das bedeutet ich muss in jeder Zeile prüfen, ob:

in der Spalte C der Wert 1 steht, dann muss die komplette Zeile in das Register Nr.1.

Wenn aber in Spalte C der Wert 2 ist, dann muss die komplette Zeile in das Register Nr. 2,

wenn der Wert in der Spalte C der Wert 3 ist, dann muss die komplette Zeile in das Register Nr. 3.


Daraufhin muss in der Originaldatei geprüft werden, ob:

in der Spalte D der Wert 5 steht, dann muss die komplette Zeile in das Register Nr.1.

Wenn aber in Spalte D der Wert 2 ist, dann muss die komplette Zeile in das Register Nr. 2,

wenn der Wert in der Spalte D der Wert 3 ist, dann muss die komplette Zeile in das Register Nr. 3.

usw.

Ich habe noch keine Makros programmiert, vielleicht kann mir jemand helfen?

Vielen Dank im Voraus...Smile
Antwortento top
#2
Hallo,

wenn du eine fertige Anwendung gebrauchen kannst, dann sieh dir mal meinen Listenseparator an.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Danke, aber leider kann ich keine Programme downloaden...
Antwortento top
#4
Hallo,

Zitat:Danke, aber leider kann ich keine Programme downloaden...

... hast Du eigentlich überhaupt mal geschaut, was Dir da zum Download angeboten wurde?
Das ist keine EXE-Datei sondern eine stinknormale *.xls-Datei.
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#5
Hallo, 19

wenn du noch nie etwas mit Makros zu tun gehabt hast, wird es schwierig. Mach es doch per Formel: 21

Code:
=WENNFEHLER(INDEX(Gesamt!A$2:A$7;AGGREGAT(15;6;ZEILE($A$2:$A$7)-1/(Gesamt!$C$2:$C$7=1);ZEILE(A1)));"")

Tabellenblattname und Bereiche natürlich noch anpassen. 21

Hier mal ein Beispiel:

.xlsx   Tabelle_Werte_aufteilen_in_Tabellenblaetter_nach_Zahlen_Spalte_C.xlsx (Größe: 13,97 KB / Downloads: 3)

Wenn du es per VBA benötigst, dann lade mal eine (aussagekräftige) Beispieldatei hier hoch.
________
Servus
Case
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste