Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Merkmale zusammenführen
#1
Hallo ihr lieben, 

wieder einmal ersuche ich eure Weisheit Smile

Ich stehe vor einem Problem was meiner Theorie nach eigtl. mit einer wenn/dann Formel gelöst werden könnte, aber ich denke es geht einfacher?

Es geht darum das verschiedene Partner, verschiedene Merkmale aufweisen können. 
Jeder dieser Partner bekommt für ein vorhandenes Merkmal ein "x". 
Am Ende soll mir Excel in einer Zelle dann alle Merkmale des Partners mit Komma getrennt eintragen.

Ich habe eine Test Tabelle als Datei eingefügt und hier auch nochmal als Screenshot, für diejenigen die nicht gerne etwas herunterladen möchtenSmile

Ich danke schon mal im Voraus !


Gruß 

Fabian

   


Angehängte Dateien
.xlsx   TEST.xlsx (Größe: 9,13 KB / Downloads: 6)
Antwortento top
#2
Zitat:Ich habe eine Test Tabelle als Datei eingefügt und hier auch nochmal als Screenshot, für diejenigen die nicht gerne etwas herunterladen möchten
Sehr sehr löblich! Mustergültig  100 100 100 15 15 15

Leider hast du noch Office 2010, da fällt mir kein sehr eleganter Weg ein (geht womöglich noch einfacher, mal sehen, welche Lösungen noch daherkommen).
Geht natürlich auch ohne Hilfsspalte - ersetze in der Formel in K2 einfach "J2" durch die Formel aus J2Smile Ich hab es nur der Übersichtlichkeit wegen mit Hilfsspalte gemacht.

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFGHIJK
1AnredeNameVorname123456
2blablibluxxxx1, 3, 4, 6,1, 3, 4, 6
3blablibluxxxx2, 3, 4, 6,2, 3, 4, 6
4blabliblux1,1
5blablibluxx4, 5,4, 5
6blablibluxxxxxx1, 2, 3, 4, 5, 6,1, 2, 3, 4, 5, 6

ZelleFormel
J2=WENN(D2="x";$D$1&", ";"")&WENN(E2="x";$E$1&", ";"")&WENN(F2="x";$F$1&", ";"")&WENN(G2="x";$G$1&", ";"")&WENN(H2="x";$H$1&", ";"")&WENN(I2="x";$I$1&", ";"")
K2=LINKS(J2;LÄNGE(J2)-2)
J3=WENN(D3="x";$D$1&", ";"")&WENN(E3="x";$E$1&", ";"")&WENN(F3="x";$F$1&", ";"")&WENN(G3="x";$G$1&", ";"")&WENN(H3="x";$H$1&", ";"")&WENN(I3="x";$I$1&", ";"")
K3=LINKS(J3;LÄNGE(J3)-2)
J4=WENN(D4="x";$D$1&", ";"")&WENN(E4="x";$E$1&", ";"")&WENN(F4="x";$F$1&", ";"")&WENN(G4="x";$G$1&", ";"")&WENN(H4="x";$H$1&", ";"")&WENN(I4="x";$I$1&", ";"")
K4=LINKS(J4;LÄNGE(J4)-2)
J5=WENN(D5="x";$D$1&", ";"")&WENN(E5="x";$E$1&", ";"")&WENN(F5="x";$F$1&", ";"")&WENN(G5="x";$G$1&", ";"")&WENN(H5="x";$H$1&", ";"")&WENN(I5="x";$I$1&", ";"")
K5=LINKS(J5;LÄNGE(J5)-2)
J6=WENN(D6="x";$D$1&", ";"")&WENN(E6="x";$E$1&", ";"")&WENN(F6="x";$F$1&", ";"")&WENN(G6="x";$G$1&", ";"")&WENN(H6="x";$H$1&", ";"")&WENN(I6="x";$I$1&", ";"")
K6=LINKS(J6;LÄNGE(J6)-2)
Schöne Grüße
Berni
Antwortento top
#3
Hey Prima danke !Smile

habe es erst so versucht :

=(WENN([@1]="x";Tabelle1[[#Kopfzeilen];[1]]&",";""))&(WENN([@2]="x";Tabelle1[[#Kopfzeilen];[2]]&",";""))&(WENN([@3]="x";Tabelle1[[#Kopfzeilen];[3]]&",";""))&(WENN([@4]="x";Tabelle1[[#Kopfzeilen];[4]]&",";""))&(WENN([@5]="x";Tabelle1[[#Kopfzeilen];[5]]&",";""))&(WENN([@6]="x";Tabelle1[[#Kopfzeilen];[6]];""))


Aber deines ist noch übersichtlicher Smile

aber einen leichteren Weg scheint es nicht zu geben?

Gruß

Fabian
Antwortento top
#4
Hier noch eine VBA-Variante. Code gehört in ein allgemeines Modul (VBA-Editor - Einfügen - Modul)

Code:
Public Function Textverbinden(Bereich As Range, Optional Trenner As String = ", ")
Dim a() As Variant
Dim zellen As Range
Dim L As Long
ReDim a(Bereich.Count)
For Each zellen In Bereich
    If zellen.Text <> "" Then
        a(L) = Cells(1, zellen.Column).Text
        L = L + 1
    End If
Next
ReDim Preserve a(L - 1)
Textverbinden = Join(a, Trenner)
End Function
Dann kannst du in J2 die Formel 
Code:
=Textverbinden(D2:I2)
eingeben und die Formel runterziehen.

Zitat:aber einen leichteren Weg scheint es nicht zu geben?
Keinen, den ich für deine Excelversion kenne. Wie gesagt, vielleicht findet einer der Cracks hier was.
Schöne Grüße
Berni
[-] Folgende(r) 1 Benutzer sagt Danke an MisterBurns für diesen Beitrag:
  • No3Fx
Antwortento top
#5
Genial !Smile

so hab ich mir das vorgestellt !!! Liebsten Dank !!!!
Antwortento top
#6
Hi

Alternativ.

J2    =WECHSELN(WECHSELN((D2<>"")*1&", "&(E2<>"")*2&", "&(F2<>"")*3&", "&(G2<>"")*4&", "&(H2<>"")*5&", "&(I2<>"")*6;"0, ";"");", 0";"")

Gruß Elex
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste