Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Datum berechnen
#1
Hallo, 

ich steh bei folgendem Problem an: In einer Zelle kann ich ein Datum meiner Wahl eintragen (Der davorgehende Sonntag wird in einer eigenen Zelle automatisch berechnet.) Ausgehend von diesem Datum soll ein eigener Kalender erstellt werden. Dieser Kalender hat in der Zeile entlang jeweils die Wochentage Mo-Fr (ein Wochentag pro Spalte) und Senkrecht in der Spalte jeweils die Kalenderwoche, eine pro Zeile, stehen. Jetzt brauch ich eine Formel, bei der von Montag weg, jeweills das Datum in die Zelle automatisch einträgt. Hat jemand eine Idee? Vielen Dank im voraus.
Antwortento top
#2
Hallo,

also, verstanden habe ich Bahnhof.
Zeige uns doch mal Deine Datei.
________________________________________________________________________
wer aufgibt, ohne es versucht zu haben, gibt einfach nur auf!

Grüße aus Norderstedt, Peter
Antwortento top
#3
Ich muss diesbezüglich hinzufügen, dass es sich hierbei um Übungsspreadsheets von meiner Firma handelt, und daher vertraulich zu behandeln sind, dies stand auch dort  wo ich es runtergeladen habe. Daher habe ich diesen Fall in einem eigenen Spreadsheet eingetragen, damit . man sihc drunter was vorstellen kann.

In der Zelle ausgewähltes Datum kann ich ein Datum meiner Wahl eintragen, dann wird eine Zeile drunter der vorherige Sonntag automatisch berechnet mittels: =WENN(ISTLEER(M18);"wird automatisch berechnet";WENN(WOCHENTAG(M18)<=2;M18+(1-WOCHENTAG(M18));M18+(1-WOCHENTAG(M18))))

Darunter dann sieht man die KWs sowie Wochentage. Eine Anmerkung: sobald ich das ausgewählte Datum eingebe öffnet es in den KWs die verbliebenen Kalenderwochen für das restliche Jahr, das macht es automatisch, ergo: Wenn ich den, sagen wir einmal 23.10.2018 eingebe, dann zeigt es in der KW Spalte automatisch alle restlichen KWs (ab KW 43) an. 

Jetzt benötige eine Formel mit der ich quasi den Montag in der KW43, auf dem Bild die Zelle F9, also das Datum automatisch berechnen kann.

Lg Oba


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#4
Moin!

Link: Datum des Montags einer vorgegebenen Kalenderwoche

Das Datum des letzten Sonntags errechnet man übrigens einfacher mittels:
=M18-REST(M18+6;7)

Gruß Ralf
Gib einem man einen Fisch und du ernährst ihn für einen Tag. 
Lehre einen man zu fischen und du ernährst ihn für sein Leben. (Konfuzius)
[-] Folgende(r) 1 Benutzer sagt Danke an RPP63 für diesen Beitrag:
  • oba vom Gas
Antwortento top
#5
Moin,

während ich noch ein wenig getüftelt habe, war Ralf um Klassen schneller. Den Link zur Montagsbestimmung hast du bekommen (den hatte ich nämlich gesucht); hier noch eine andere Verkürzung der Sonntagsberechnung:

Arbeitsblatt mit dem Namen 'Tabelle1'
AB
1DatumDi 23.10.2018
2SonntagSo 21.10.2018

ZelleFormatWert
B1TTT TT.MM.JJJJ23.10.2018
B2TTT TT.MM.JJJJ21.10.2018

ZelleFormel
B2=B1-WOCHENTAG(B1;2)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • oba vom Gas
Antwortento top
#6
Danke für eure Beiträge,

ich habe mich letztendlich für Willwissen´s Vorschlag entschieden, da, wie ich bei den Lösungsvorschlägen von RPP 63 eine eigene Zelle einfügen muss, die eigens das Kalenderjahr abbildet. 

Lg oba
Antwortento top
#7
jetzt habe ich dafür eine neue Formel, die funktioniert dann auch, anhand der formel von Willwissen konnte ich nur den Sonntag ermitteln.
=WENN($H23=KALENDERWOCHE($M$18);$M$19+I22+1;I22+7). H23 ist die Spalte mit den KW´s, M18 ist der ausgewählte Tag, M19 der Sonntag, I22  die Zelle wo Montag drinnsteht. Für Vereinfachungen wäre ich dankbar.

lg Owa
Antwortento top
#8
Hallöchen,

eventuell I22+1 ausklammern?

=I22+1+WENN($H23=KALENDERWOCHE($M$18);$M$19;6).
   \\\|///      Hoffe, geholfen zu haben.
   ( ô ô )      Grüße, André aus G in T  
 ooO-(_)-Ooo    (Excel 97-2016)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste