Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Dropdown mit Vorauswahl
#1
Hallo Zusammen,

ich habe von meinem Vorgesetzten die Frage bekommen ob es möglich ist in einer Zelle mit DropDown-Liste ein Wort hineinzuschreiben und dann eine Vorgabe von allen Inhalten zu bekommen, die dieses Wort enthalten?

Ich hoffe ich kann es an einem Beispiel besser erklären.

Nehmen wir an in der DropDown gibt es folgenden Möglichkeiten:
  • Bank Ireland
  • Bank France
  • Versicherung Ireland
  • Lieferant Ireland
  • Versicherung France
  • Lieferant France
Nun schreibe ich in die Zeile "Ire" rein, nun möchte mein Vorgesetzter, dass nur noch die drei Punkte mit "Ireland" angezeigt werden.

Ist das überhaupt möglich? Ich habe mir bereits Gedanken über ein Makro gemacht, aber das ganze soll ohne Makro funktionieren.

Ich hoffe hier kann mir jemand helfen.

Vielen Dank Vorab.

Schöne Grüße
Antwortento top
#2
Hallo,

so vielleicht?

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEF
1SucheErgebnisHilfstabelle
2IreBank FranceBank Ireland2
3Lieferant IrelandBank France
4Versicherung FranceVersicherung Ireland4
5Lieferant Ireland5
6Versicherung France
7Lieferant France

ZelleFormel
B2=WENNFEHLER(INDEX($E$2:$E$7;KKLEINSTE($F$2:$F$7;ZEILE(A1)));"")
F2=WENNFEHLER(WENN(VERGLEICH("*"&$A$2&"*";E2;0)=1;ZEILE();"");"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#3
Hi,

da ich mich nicht mit fremden Federn schmücken möchte hier ein sehr gut gemachtes Video - das sollte dein Problem lösen. Im Prinzip filterst du quasi deine Originalauflistung in einer Zusatzliste:

https://www.youtube.com/watch?v=AcQHleyCtB8

Gruß Tim
Antwortento top
#4
Hallo WillWissen,

danke für die rasche Antwort.

Nicht ganz :(

Ich versuch es nochmal besser zu erklärenSmile

In A1 habe ich eine DropDown-Liste mit den oben genannten Möglichkeiten. Mein Vorgesetzter schreibt jetzt in A1 "Ire" rein, dann sollen die sechs Möglichkeiten nur noch auf diese reduziert werden in denen "ire" vorkommt. D.h. die DropDown-Liste wird auf drei Möglichkeiten reduziert.

Ich weiß ist eine idiotische Vorgabe und ohne Makro wahrscheinlich auch nicht wirklich umsetzbar, aber ihr wisst ja wie das mit Vorgesetzten so ist :D

Grüße.
Antwortento top
#5
Hallo EasY,

das sieht schonmal gut aus danke, werd ich gleich mal ausprobieren :D

danke
Antwortento top
#6
Hi,

in der selben Zelle geht das mit Bordmitteln nicht. Bei meinem Beispiel brauchst du eine Suchzelle - hier z.B. A2. Daneben kannst du das Ergebnis entweder so schreiben lassen, wie ich es gezeigt habe. Oder mit einem Dropdown (aber auch neben der Suchzelle) so:

Arbeitsblatt mit dem Namen 'Tabelle1'
ABCDEFG
1SucheErgebnisHilfstabelleDropdown
2ireVersicherung IrelandBank Ireland2Bank Ireland
3Bank FranceVersicherung Ireland
4Versicherung Ireland4Lieferant Ireland
5Lieferant Ireland5
6Versicherung France
7Lieferant France

ZelleFormel
F2=WENNFEHLER(WENN(VERGLEICH("*"&$A$2&"*";E2;0)=1;ZEILE();"");"")
G2=WENNFEHLER(INDEX($E$1:$E$7;KKLEINSTE($F$2:$F$7;ZEILE(A1)));"")

ZelleGültigkeitstypOperatorWert1Wert2
B2Liste=$G$2:$G$7
B3Liste=$G$2:$G$7
B4Liste=$G$2:$G$7
B5Liste=$G$2:$G$7
B6Liste=$G$2:$G$7
B7Liste=$G$2:$G$7
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#7
Hallo WillWissen,

danke, das hab ich mir schon gedacht. Werde jetzt mal beide Varianten meinem Vorgesetzten zeigen. Mal schauen was er dazu meint oder ob wieder eine neue aufregende Anforderung findet :D

Trotzdem vielen dank für deine schnelle HilfeSmile

Viele Grüße
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste