Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel zeigt auch falsche Ergebnisse an, warum?
#1
Hallo,

auf der Suche nach einer Formel die wie Sverweis funktioniert. aber mehrere Ergebnisse ausspucken soll, wurde mir die untenstehende gezeigt.
Funktioniert auch gut, nur zeigt sie jetzt auch falsche Ergebnisse an. Woran liegt das?

{=WENNFEHLER(INDEX(Stammdaten!K:K;KGRÖSSTE((Stammdaten!$A$2:$A$39155=Übersicht!$H$43)*(ZEILE(Stammdaten!$A$2:$A$39155)-1);ZÄHLENWENN(Stammdaten!$A$2:$A$39155;$H$43)+1-ZEILE(A6)));"")}

Übersicht!H43 ist eine Zelle wo eine Kundennummer drin steht.
Wenn ich dir Formel nun eingebe, zeigt er mir aber auch Kunden an, die eine ganz andere Kundennummer haben.

Wo ist mein Fehler?
Antwortento top
#2
Hola,

und wie sollen wir das beantworten ohne die Datei oder eine identisch aufgebaute Beispieldatei zu sehen?

Gruß,
steve1da
Antwortento top
#3
Würde ich gerne, aber in meiner Beispieldatei für euch funktioniert es.
Und das Original kann ich aufgrund von vertraulichen Daten nicht reinstellen.
Antwortento top
#4
Hola,

dann ist die Beispieldatei nicht so aufgebaut wie das Original.

Gruß,
steve1da
Antwortento top
#5
Doch, sie umfasst nur deutlich weniger Daten im Vergleich zum Original.
Gibt es nicht sowas wie ungeschriebene Regeln die man beachten muss?

Was ist denn eine häufige Fehlerquelle wenn Excel falsche Datenwerte bei sowas ausgibt?
Antwortento top
#6
Fehler gefunden..
Beim Runterziehen habe ich das nicht festgesetzt, aus diesem Grund hat er wohl falsche Ergebnisse genommen...
Antwortento top
#7
Hola,


Zitat:Beim Runterziehen habe ich das nicht festgesetzt,


was auch immer "das" ist. Hauptsache es geht wieder

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • elamigo
Antwortento top
#8
"das" war quasi der erste Bezug, also das, was wiedergegeben werden soll.

Aber nun habe ich ein anderes Problem.
Kann Excel kein Datum damit wiedergeben? - Wenn ich es auf die Zellen mit dem Datum anwende, dann gibt er immer nur "0" wieder...
Antwortento top
#9
Hola,

Excel gibt alles wieder, auch Datumswerte.

Gruß,
steve1da
Antwortento top
#10
Im Anfängerkurs lernt man, dass Formeln immer nur Werte, nicht automatisch immer auch deren Formate, übernehmen. Auch wenn das oft durchbrochen wird, gilt das noch heute so.
[-] Folgende(r) 1 Benutzer sagt Danke an LCohen für diesen Beitrag:
  • elamigo
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste