Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Sverweis Matrix mit Bezug in Quelle
#1
Hallo, 

nehmen wir an, ich habe folgenden Sverweis:

=SVERWEIS(E12;'C:\Users\PC\Desktop\[2.xlsx]Tabelle1'!$F$13:$H$16;1;FALSCH)

Weiß jemand wie die Zahl "2" in der Matrixquelle aus eine anderen Zelle kommt? Z.b. so:

=SVERWEIS(E12;'C:\Users\PC\Desktop\[A1.xlsx]Tabelle1'!$F$13:$H$16;1;FALSCH)

A1=2

Geht sowas ähnliches? Die zweite Funktion funktioniert nämlich nicht dieser Art.
Antwortento top
#2
Moin

Du suchst INDIREKT(). Allerdings muss die Quelldatei immer geöffnet sein.
Alternativ: VBA- oder PQ-Lösungen.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Weißt du wie die Sverweis Formel dann mit indirekt aussehen muss?
Antwortento top
#4
Ungetestet.

Code:
=SVERWEIS(E12;INDIREKT("'C\Users\PC\Desktop\["&A2&"}Tabelle1'!F13:H16");1;FALSCH)
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
[-] Folgende(r) 1 Benutzer sagt Danke an shift-del für diesen Beitrag:
  • chrissy
Antwortento top
#5
=SVERWEIS(E12;INDIREKT("F10.xlsx"&"Tabelle1!$F$14:$G$16";WAHR);2;FALSCH)

Das hier funktioniert nicht.
Antwortento top
#6
(08.04.2019, 19:34)shift-del schrieb: Ungetestet.

Code:
=SVERWEIS(E12;INDIREKT("'C\Users\PC\Desktop\["&A2&"}Tabelle1'!F13:H16");1;FALSCH)

Da steht #BEZUG!
Antwortento top
#7
Jetztz geht es. 

=SVERWEIS(E12;INDIREKT("'C:\Users\PC\Desktop\["&A1&"]Tabelle1'!F14:G16");2;FALSCH)

Aber nur wenn ich diese Zieldatei auch geöffnet habe. Sonst kein Bezug. 


Es gibt aber ein Problem. Wenn ich z.b. 100 Spalten habe und somit 100 Quellen.

Dann kann ich nicht alle 100 Quellen öffnen. Damit alles angezeigt wird. Gibt es keine Alternativen?

Das geht leider auch nicht =SVERWEIS(E12;VERKETTEN("C:\Users\PC\Desktop\";"[";A1;".xlsx]";"Tabelle1!$F$14:$G$16");2;FALSCH)
Antwortento top
#8
Das hier funktioniert zwar, aber ich muss die Quelle manuall auswählen, wenn ich enter drücke. Er hollt sich den Wert in A1 nicht aus der Zelle. 

=SVERWEIS($E$12;'C:\Users\PC\Desktop\[&A1&.xlsx]Tabelle1'!$F$14:$G$16;2;FALSCH)

Ich hab auch das hier probiert.

Es geht aber überhaupt nicht

https://www.controllingportal.de/Fachinf...assen.html
Antwortento top
#9
Steht alles in #2.
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#10
Hiermit funktioniert es:

="='C:\Eigene Dateien\["&A1&".xls]Tabelle1'!$A$1" 

Danach als Werte speichern. 
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste