Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Negative Stundenzeiten in negative (Dezimal)zahl umwandeln
#1
Liebe Forum-Mitglieder,

wir sehen uns mit einem Problem konfrontiert, was recht schnell einer Lösung bedarf und hoffen hier sehr auf eure Unterstützung ;)

Folgender Fall:

Wir haben eine Überstundenliste erstellt, in der Soll-Ist-Zeiten miteinander abgeglichen werden und am Ende Plus-oder Minusstunden ausgewiesen werden. Für die Berechnung der Zeiten haben wir folgende Formel verwendet: 

=TEXT(ABS(SUMME(H3:H39)-SUMME(G3:G39));WENN(SUMME(H3:H39)
Bis hierhin läuft alles prima. 

In einer separaten Zusammenfassung sollen die monatlichen Plus-oder Minusstunden automatisch als Zahl wiedergegeben werden. Bei Plusstunden funktioniert es, indem wir zuerst eine Dezimalzahl erstellen und diese dann folgendermaßen umwandeln: 

=WECHSELN(K36;"-";)*(1-(RECHTS(K36;1)="-")*2) --> Dezimalzahl wird aus der Stundenzahl erstellt und dann mit 24 multipliziert (=M36*24)

Bei positiven Werten funktioniert das prima, aber negative Werte werden immer positiv angezeigt. Habt ihr eine Lösung dafür parat?

Wir freuen uns sehr auf eure Ideen und Vorschläge! 

Danke


Angehängte Dateien
.xls   Überstunden.xls (Größe: 84 KB / Downloads: 10)
Antwortento top
#2
Moin

Wäre LINKS() nicht sinnvoller?
Wir sehen uns!
... shift-del
Hinweise zu meiner Hilfe in Foren
Excel Super-Funktionen: VERWEIS(), INDEX(), WAHL()
Antwortento top
#3
Hallo Lufi,

ich würde überhaupt nicht mit Texten arbeiten.

Arbeitsblatt mit dem Namen 'Januar'
GHIJKL
38:158:15
48:158:15
58:158:15
65:305:30
7
8
98:159:151:00
108:155:153:00
118:155:153:00
128:156:152:00
135:305:30
14
15
168:1510:152:00
178:158:15
188:1510:152:00
198:158:15
205:305:30

ZelleFormatWert
K3h:mm;;0
L3h:mm;;0

ZelleFormel
K3=(H3-G3)*(G3<=H3)
L3=(G3-H3)*(H3<=G3)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Zusammenfassung'
AB
1Januar
2Aufgebaute Überstunden-3,00

ZelleFormatWert
B20,00-3

ZelleFormel
B2=(Januar!K36-Januar!L36)*24
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Ich habe die Plus- und Minuszeiten separat in zwei Spalten berechnet.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
Antwortento top
#4
http://www.office-hilfe.com/support/show...xtbereiche

(dort: Negative Zeiten)
Antwortento top
#5
Hallo Lufi,

Excel kann ganz normal mit negativen Zeiten rechnen. Nur mit der Darstellung klappt es nicht direkt. Aber die kann man ja entsprechend anpassen und die Berechnungsspalte (hier C) ausblenden:

ABCD
1IstSollSaldoSaldo
206:3008:30#####-02:00
310:0008:3001:3001:30
4#####-00:30
Formeln der Tabelle
ZelleFormel
C2=A2-B2
D2=WENN(C2<0;"-";"")&TEXT(ABS(C2);"[HH]:MM")
C3=A3-B3
D3=WENN(C3<0;"-";"")&TEXT(ABS(C3);"[HH]:MM")
C4=SUMME(C2:C3)
D4=WENN(C4<0;"-";"")&TEXT(ABS(C4);"[HH]:MM")

Gruß Uwe
Antwortento top
#6
Hallo Lufi,

da du kein Datum verwendest und auch nicht Verknüpfungen zu anderen Mappen hast würde ich 1904 empfehlen.
Dann stellen "Minusuhrzeiten" kein Problem dar.

Nur sollte einem klar sein was dann eingestellt wird!
https://support.microsoft.com/de-at/help...m-in-excel

kleines Video
https://www.youtube.com/watch?v=dzTMVo64VrM

und hier deine Datei

.xlsx   Überstunden.xlsx (Größe: 20 KB / Downloads: 2)
lg Chris
Feedback nicht vergessen.
[Bild: v.gif]
3a2920576572206973742064656e20646120736f206e65756769657269672e
[-] Folgende(r) 1 Benutzer sagt Danke an chris-ka für diesen Beitrag:
  • elamigo
Antwortento top
#7
Hallo an alle!!!

Danke für die super schnellen Rückmeldungen und eure Hilfe! Das Problem hat sich gelöst mit euren TippsSmile

Liebe Grüße,

Lufi!
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste