Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Index/KGrösste/Zeile
#1
Hi Leute,

ich habe eine intelligente Datentabelle "Tabelle1" auf dem Blatt "Tabelle1". Nun möchte ich diese Auflistung schön dargestellt auf einem anderen Blatt "Tabelle2" darstellen. Ich habe auch schon eine passende Formel gefunden, kann sie an meine Gegebenheiten (anderer Platz auf dem jeweiligen Blatt) aber leider nicht anpassen. Für euch ist das sicher kein Problem, das entsprechend anzupassen.

Vielleicht seid ihr auch so nett und könntet mir erklären, welche Formelbestandteile wofür zuständig sind ... dann kann ich die Formel später bei Bedarf selber weiter anpassen.


Anbei eine Beispielmappe mit Wunschergebnis und die bisherige Formel in Tabelle2!G9

Vielleicht habt ihr ja auch eine bessere Alternative? Für eine Pivot scheine ich zu doof zu sein ... habe mich damit aber auch bislang nie richtig beschäftigt. Der Aufbau soll aber schon so sein, wie er in dem Beispiel ist.


Gruß Tim


Angehängte Dateien
.xlsx   Index_Kgroesste.xlsx (Größe: 10,66 KB / Downloads: 4)
Antwortento top
#2
Hola,

ohne Matrix-Abschluss:

Code:
=WENNFEHLER(INDEX(Tabelle1!$B$9:$B$16;AGGREGAT(15;6;ZEILE($A$9:$A$16)-8/(Tabelle1!$A$9:$A$16=G$8);ZEILE(A1)));"")

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • EasY
Antwortento top
#3
Unfassbar Steve,

in was für einem Tempo solche Lösungen präsentiert werden - Danke!
Antwortento top
#4
Hossa,

muss den Thread doch noch einmal reaktivieren:

Gibt es eine Möglichkeit, einen Eintrag zu überspringen, wenn z.B. in Tabelle1!C9 ein "X" steht? In der Form, dass er den Meier nicht mit auflistet?

Und wie wäre dann die Formel, um genau diese Einträge mit dem "X" dann an anderer Stelle aufzuführen?


Gruß
Antwortento top
#5
Hallo Easy,

meine nachfolgende Formel ist zwar länger als die von steve1da, wertet aber Deine "intelligente" Tabelle aus (also nicht absolut)  und zwar so, dass nachfolgende Formel nicht nur nach unten sondern auch nach rechts ziehend kopiert werden kann. Vor allem ist die Formel "immun" gegen Verschiebungen der Datentabelle und auch der Auswertungstabelle, was von Vorteil sein kann.

Arbeitsblatt mit dem Namen 'Tabelle2'
GHIJ
8BA1BA2BA3BA4
9MeierOttoFresnerKarl
10MüllerKrönertIdo
11Schulz
12

ZelleFormel
G9=WENNFEHLER(INDEX(INDEX(Tabelle1[#Alle];;2);AGGREGAT(15;6;(ZEILE(Tabelle1[#Alle])-ZEILE(Tabelle1[[#Kopfzeilen];[Name]])+1)/(INDEX(Tabelle1[#Alle];;1)=G$8);ZEILE()-ZEILE(G$8)));"")
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • EasY
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste