Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Statistik Schüler-Jahr mit ZÄHLENWENNS?
#1
Hallo zusammen,

ich habe eine Tabelle mit Unterrichtsstunden
A: Datum
B: Name des Schülers

und möchte eine Statistik erstellen mit einer Tabelle
D: Name des Schülers
E: 2017
F: 2018
G: 2019
....
In den Zellen sollen die Anzahl der Unterrichtsstunden pro Schüler und pro Jahr stehen.

Mit ZÄHLENWENNS komme ich nicht weiter, weil ich im Spaltenkopf von E, F, G, ... nur das Jahr stehen habe, in Spalte A aber das Datum (bzw. habe ich keine Methode gefunden, um innerhalb von ZÄHLENWENNS aus dem Wert der Spalte A das Jahr zu machen und es dann mit dem Spaltenkopf von E, F, G, ... zu vergleichen).

Bisher habe ich mir damit geholfen, eine zusätzliche "Statistik-Spalte"
C: =JAHR(A)&B
zu machen und dann einfach in der Statistiktabelle mit ZÄHLENWENN(C:C;$D2&E$1) die Werte einzufügen. Das sollte aber doch auch ohne diese "Krücke" mit der Spalte C funktionieren, oder?

Hat jemand Tipps oder eine Lösung für mich? Ich bedanke mich aufs herzlichste für jede Anregung!
Stefan
Antwortento top
#2
Hallo Stefan,

mit etwas mehr Einsicht in den Aufbau deiner Datei sollte das kein Problem sein. Möglicherweise kann man auch mit Summenprodukt zu einem Ergebnis kommen. =Summenprodukt((Jahr(A2:A100)=E$1) … usw.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
Photo 
Hallo Klaus-Dieter,

danke für die schnelle Reaktion. Ich poste hier mal einen Screenshot von einer Beispieltabelle. In Anlage die Beispieltabelle.

Das Ziel ist der Verzicht auf die "Statistik-Spalte" C und das direkte Berechnen der Anzahl Stunden pro Schüler in den Zellen E2:G4 aus den Spalten A und B.

Vielen Dank!


Angehängte Dateien
.xlsx   excelforum1.xlsx (Größe: 11,19 KB / Downloads: 8)
Antwortento top
#4
Hallo Susi,

statt eines Bildschirmfotos wäre eine Beispieldatei besser gewesen, dann brauche ich die nicht nachbauen.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#5
Hallo Klaus-Dieter, ich habe nicht gesehen, dass ich Attachments anfügen kann. Im obigen Post geändert/aktualisiert. Danke! Stefan
Antwortento top
#6
Hallo Stefan,

so sollte das gehen:

Tabelle1

ABCDEFG
1DatumName des SchülersName des Schülers201720182019
205.04.2017Maier, SusiMaier, Susi111
306.08.2017Müller, HansMüller, Hans120
423.11.2017Schmitt, RudiSchmitt, Rudi102
505.02.2018Maier, Susi
610.04.2018Müller, Hans
725.06.2018Müller, Hans
806.01.2019Schmitt, Rudi
904.02.2019Maier, Susi
1013.03.2019Schmitt, Rudi
11
Formeln der Tabelle
ZelleFormel
E2=SUMMENPRODUKT((JAHR($A$2:$A$10)=E$1)*($B$2:$B$10=$D2))
F2=SUMMENPRODUKT((JAHR($A$2:$A$10)=F$1)*($B$2:$B$10=$D2))
G2=SUMMENPRODUKT((JAHR($A$2:$A$10)=G$1)*($B$2:$B$10=$D2))
E3=SUMMENPRODUKT((JAHR($A$2:$A$10)=E$1)*($B$2:$B$10=$D3))
F3=SUMMENPRODUKT((JAHR($A$2:$A$10)=F$1)*($B$2:$B$10=$D3))
G3=SUMMENPRODUKT((JAHR($A$2:$A$10)=G$1)*($B$2:$B$10=$D3))
E4=SUMMENPRODUKT((JAHR($A$2:$A$10)=E$1)*($B$2:$B$10=$D4))
F4=SUMMENPRODUKT((JAHR($A$2:$A$10)=F$1)*($B$2:$B$10=$D4))
G4=SUMMENPRODUKT((JAHR($A$2:$A$10)=G$1)*($B$2:$B$10=$D4))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • StefanSK
Antwortento top
#7
Hallo Klaus-Dieter,

das ist genial. Herzlichen Dank für deine spontane und schnelle Hilfe!

Viele Grüße,
Stefan
Antwortento top
#8
Hallo Stefan,

du hast zwar eine Formellösung. Mit ein paar wenigen Mausklicks und völlig ohne Formeln und VBA: Pivottabelle

Dazu ziehst du "Datum" in Spalten, "Schüler" in Zeilen und "Datum" in Werte. Es werden dir von Excel im Feld Spalten automatisch noch Quartale und Jahre angelegt. Hier entfernst du einfach Quartale und Datum.

Gesamtergebnisse für Zeilen und Spalten kannst du unter Entwurf (siehst du in der Menüleiste, wenn der Cursor irgendwo in der PT steht) deaktivieren.

So siehts nach ein wenig Kosmetik aus:

   

Ein Bild deshalb, weil das Tabellentool eine PT nicht richtig abbildet.
Gruß Günter
Misserfolg ist eine Chance, es beim nächsten Mal besser zu machen.
(Henry Ford) www.sprueche-zum-nachdenken.eu
[-] Folgende(r) 1 Benutzer sagt Danke an WillWissen für diesen Beitrag:
  • StefanSK
Antwortento top
#9
Hallo, das geht auch ohne SUMMENPRODUKT() - mit SUMME(). Auch alternativ zu PivotTable ("schöner") mit Power Query.
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste