Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

AbgeänderteSUMMEWENN
#1
Hallo,

ich bin leider ziemlich neu hier und was Excel anbelangt auch noch ein Anfänger. Mein Hauptproblem bei der Lösungssuche ist, dass ich nicht genau weiß wie ich mein Problem beschreiben soll. Ich habe folgendes Problem:

Ich habe eine Tabelle in der bestimmte Methoden mit Eigenschaften stehen. Außerdem habe ich eine zweite Tabelle in der Beziehungen zwischen verschiedenen "Methoden" stehen. Ich möchte jetzt für eine Methode die Summe der Eigenschaft bilden, wenn die Methoden eine Beziehung mit der jeweiligen Methode haben. Als Beispiel: Die Methode "M1" hat eine Beziehung von "V100" zu den Methoden "M3" und "M5" also ergibt sich für "M1" die Summe 5+2=7. Mit der SUMMEWENN Funktion komme ich hier nicht weiter, da wenn ich den Bereich in der anderen Tabelle angeben die Zeilen nicht weiter gezählt werden, sondern in den Spalten weiter gegangen wird. Gibt es hierfür eine Formellösung? (Spiegeln der Matrix ist keine Option)

PS.: Ich habe mal noch eine Beispielexcel mit Bild zur Erklärung hinzugefügt.


Angehängte Dateien Thumbnail(s)
   

.xlsx   Problemexcel.xlsx (Größe: 9,54 KB / Downloads: 7)
Antwortento top
#2
Hallo U...,

zb so (für C2):
Code:
{
=SUMMENPRODUKT($B$2:$B$6*MTRANS(INDEX(($F$2:$J$6<>"-")*1;VERGLEICH(A2;$E$2:$E$6;0);)))
}
Achtung!  Matrixformel! Die geschweiften Klammern werden nicht mit eingefügt, sondern jede Bearbeitung der Formel wird mit Strg+Shift+Enter abgeschlossen.
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





[-] Folgende(r) 1 Benutzer sagt Danke an Ego für diesen Beitrag:
  • UnwissenderStudent
Antwortento top
#3
(06.04.2019, 12:15)Ego schrieb: Hallo U...,

zb so (für C2):
Code:
{
=SUMMENPRODUKT($B$2:$B$6*MTRANS(INDEX(($F$2:$J$6<>"-")*1;VERGLEICH(A2;$E$2:$E$6;0);)))
}
Achtung!  Matrixformel! Die geschweiften Klammern werden nicht mit eingefügt, sondern jede Bearbeitung der Formel wird mit Strg+Shift+Enter abgeschlossen.


Hallo,

super, vielen vielen vielen Dank  Angel für die Zeit die du investiert hast. Ich komme mir zwar ziemlich blöd vor mit dem MTRANS, aber habe heute den ganzen morgen damit verbracht so einen Befehl zu googlen und dieser Befehl wurde mir nie vorgeschlagen.

Viele Grüße und einen schönen Tag.
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste