Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Differenz mit Dedingungen über mehrere Tabellenblätter
#1

.xlsx   Verbrauchsdaten Fuhrpark 2019 Test.xlsx (Größe: 18,17 KB / Downloads: 7)

Hi Leute,

habe folgende Herausforderung, stehe aber mal wieder auf dem Schlauch.

Auf dem Tabellenblatt KM sind in Spalte A4 bis..... Kennzeichen. Auf dem Tabellenblatt KMG Spalte A Datum / B Kenzeichen, C Kilometerstand.

Ich suche eine Formel in der die  Kilometerdifferenz mit den Kriterien Kennzeichen und Jahr da  die jeweilig gefahrenen KM wiedergibt. Die Kilometerdaten werden fortlaufend weitergeschrieben, deswegen das Jahr als Kriterium 

Beispieldatei im Anhnag

im Prinzip soll auf dem Tabellenblatt KM, in der Zelle F4 die Kilometerdifferenz des Jahres 2019 wiedergegeben werden. Ohne dass man die Auswahldaten auf das Jahr beschränken muss.

Ich hab schon gebastelt mit Wenn, Dann in Verbindung mit Differenz bzw. mit KK und min, aber irgendwie will es nicht funzen.

Hilfe wäre nett, im voraus vielen Dank

Beispieldatei im Anhang

Grüße Rayker
Antwortento top
#2
Hola,

Code:
=MIN(WENN((KMG!$B$2:$B$340=A4)*(JAHR(KMG!$A$2:$A$340)=2019);KMG!$C$2:$C$340))

Das ist eine Matrixformel die mit Strg-Shift-Enter abgeschlossen werden muss.

Gruß,
steve1da
Antwortento top
#3
Daaaankke!!!!!
Antwortento top
#4
Hallo, ich würde das mit einer Hilfstabelle (per Power Query - ganz einfach mit Gruppieren erstellt - ) lösen und die Daten per SVERWEIS() ohne (komplizierte) Matrixformel holen...

Arbeitsblatt mit dem Namen 'KMG'
ABCDEFGHI
1DatumKennzeichenKilometerstandKennzeichenMinMax
201.07.2015DAM26842.995,00BODL563149898151207
301.08.2015DAM26847.106,00BOLL5632106143107058
401.09.2015DAM268410.339,00CLCS1456881770563
501.10.2015DAM268413.491,00DAM2684135326144472
601.11.2015DAM268416.550,00HHKL562300
701.01.2016DAM268422.879,00KLOP8968897390840
801.02.2016DAM268426.024,00LKUI5235791458550
901.03.2016DAM268429.106,00MAKL1425141956143123
1001.04.2016DAM268432.458,00
1101.05.2016DAM268436.088,00
1201.06.2016DAM268437.999,00
1331.12.2016DAM268461.039,00
1401.01.2017DAM268461.039,00
1501.02.2017DAM268464.402,00
1601.03.2017DAM268467.294,00
1701.04.2017DAM268470.656,00
1801.05.2017DAM268473.925,00
1901.06.2017DAM268477.164,00
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'KM'
ABCDEFG
3KennzeichenFahrzeugartHerstellerModellMotorStartEnde
4CLCS145PiaggioPiaggioRollerBenzin6881770563
5DAM2684PkwVolkswagenCaddyDiesel135326144472
6MAKL1425TransporterOpelMovano 2.5 DDiesel141956143123
7BODL563PkwCitroenBerlingoDiesel149898151207

ZelleFormel
F4=SVERWEIS($A4;Tabelle1_2[#Alle];2;0)
G4=SVERWEIS($A4;Tabelle1_2[#Alle];3;0)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste