Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zählen von Text und addieren von Zahlen mit mehreren Kriterien
#1
Hey Forum,

ich suche nach einer Möglichkeit einen Buchstaben "x" zu Zählen und je nach dem ob es ein Tag von Mo - Fr ist soll +20 gerechnet werden und wenn es Sonntag ist +25.

Am Besten in einer Formel falls möglich. Blush  


Habe Zählenwenns und und und probiert und bin gescheitert. Kennt jemand einen Lösungsweg?

Vielen Dank

ExcelAzubi



.xlsx   Beispieldatei-Zählen.xlsx (Größe: 8,46 KB / Downloads: 7)
Antwortento top
#2
Hola,

hier mal für alles außer "so":


Code:
=ZÄHLENWENNS(A4:A31;"<>so";D4:D31;"x")*20

Den Rest schaffst du alleine Wink

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • ExcelAzubi777
Antwortento top
#3
Hallo,

so:
Code:
=SUMMENPRODUKT(($D$4:$D$31="x")*(20+($A$4:$A$31="So")*5))

Aber was soll an einem Samstag gerechnet werden? 20? 25?
Gruß
Michael
[-] Folgende(r) 1 Benutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • ExcelAzubi777
Antwortento top
#4
Tut mir leid an einem Samstag soll auch +20 gerechnet werden
Antwortento top
#5
Hey Danke Steve1da,

so funktioniert es in zwei getrennten Spalten.

Dafür vielen Dank.

Gibt es eine Möglichkeit die beiden Formeln dann zu einer zu machen?
Antwortento top
#6
Hast Du meine Formel getestet? Ist schon alles in einer Formel vereint!
Gruß
Michael
[-] Folgende(r) 1 Benutzer sagt Danke an Der Steuerfuzzi für diesen Beitrag:
  • ExcelAzubi777
Antwortento top
#7
Hola,


Zitat:Gibt es eine Möglichkeit die beiden Formeln dann zu einer zu machen?

Zählenwenns(....)+Zählenwenns(....)

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • ExcelAzubi777
Antwortento top
#8
Tongue 
Hey Steuerfuzzi  Blush ,

danke für die Lösung!!!!

Kannst du mir die Formel aber bitte erklären?
Antwortento top
#9
Hola,

wenn du mir eine PN schickst, selber aber den Empfang von PN's deaktiviert hast, ist das nicht hilfreich.
Außerdem bleibe bei Fragen zum Thread bitte im Thread und lade eine aktuelle Beispieldatei hoch, die so aussieht, wie halbwegs in der PN beschrieben.

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • ExcelAzubi777
Antwortento top
#10
Hola,

danke für deine Antwort. Blush

So sieht die Tabelle aktuell aus:


.xlsx   Beispieldatei2.xlsx (Größe: 17,43 KB / Downloads: 9)


Die automatisierten Tage und das Datum waren schon vorhanden und es sollte so beibehalten werden.

Habe versucht die Zellbezüge anstatt "So" zu verwenden aber dann wird die Formel nicht als Formel erkannt

Vielen Dank für jede Art von Hilfe.

Gruß ExcelAzubi
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste