Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Formel für Plz-Separierung
#1
Hi zusammen,

ich habe einen großen Datensatz bei dem in einer Spalte die gesamte Adress-Information gespeichert werden. Die Schreibweise ist hierbei ganz unterschiedlich - leider. Im Anhang ein Beispiel-Datensatz. Ich bräuchte eine Formel - die mir immer die Postleitzahl in die danebenliegende Zelle schreibt. Geht das bei einem derartig unterschiedlichen Aufbau der Adress-Zellen? Die einzige Gemeinsamkeit ist die, dass jede Postleitzahl eine 5-stellige Zahlenabfolge darstellt. In Ostdeutschland beginnnen diese mit 0.

Würde mich über HIlfe sehr freuen.

LG Felix


Angehängte Dateien
.xlsx   Beispiel.xlsx (Größe: 9,69 KB / Downloads: 8)
Antwortento top
#2
Hi Felix,

so:

=WENNFEHLER(VERWEIS(9^99;--TEIL(WECHSELN(WECHSELN(A2&"#";" ";"");"-";"");SPALTE(1:1);5));"")

Google hilft!Smile
Quelle: http://www.office-loesung.de/ftopic560869_0_0_asc.php

LG
Alexandra
[-] Folgende(r) 1 Benutzer sagt Danke an cysu11 für diesen Beitrag:
  • Felix_VR
Antwortento top
#3
Hallo

Oder ohne Formel mit der Blitzvorschau.
Grüsse
Detlef

Bitte keine PN!
Seit Nikolaus 2012 mit Excel 2010. Seit Ostern 2015 mit Office 365
Antwortento top
#4
Nimm das:
PHP-Code:
=WENNFEHLER(TEXT(VERWEIS(9^99;--TEIL(WECHSELN(WECHSELN(A2&"#";" ";"");"-";"");SPALTE(2:2);5));"00000");""

Dann klappts auch mit der "Null" für den Osten der Republik.
Lies den Fred im Office Forum weiter, da kommt noch mehr.
Antwortento top
#5
Super, danke. Hat funktioniert Smile
Antwortento top
#6
Hallo, 19

als Alternative - RegExp: 21

Code:
Option Explicit
Function fncZahl(strTMP As String) As String
    Dim objRegEx As Object
    Dim objValue As Object
    Set objRegEx = CreateObject("VbScript.RegExp")
    With objRegEx
        .Pattern = "\d{5}"
        Set objValue = .Execute(strTMP)
        If objValue.Count Then
            fncZahl = objValue(0)
        Else
            fncZahl = "Keine PLZ!"
        End If
    End With
    Set objValue = Nothing
    Set objRegEx = Nothing
End Function

Code in ein Modul und dann in B2 "=fncZahl(A2)" und runterziehen. 21
________
Servus
Case
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste