Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Eingaben aus Katalog wiedergeben
#1
Hallo zusammen,

ich bin mit Excel leider nicht sehr gut und brauche daher dringend eure Hilfe! Ich habe folgendes Problem:

Ich habe in beigefügter Excel Datei auf dem 2. Tabellen-Blatt einen F-Systemkatalog. Ein F-System besteht immer aus einer Kombination von E-Systemen.

Die Eingaben in Spalte B im ersten Tabellenblatt sind per Drop-Down Menü auf die Eingabe der E-Systeme aus dem F-Systemkatalog beschränkt. In jeder Zeile kann nur ein E-System eingegeben werden.

Die Funktion die ich gerne hätte wäre folgende: Sobald eine der E-System Kombinationen in den Zellen der Spalte B auftaucht, soll es in Zelle A2 den Namen des F-Systems eintragen.

Funktioniert das ohne weiteres?

Für eure Hilfe bin ich euch sehr dankbar.

Liebe Grüße


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 12,06 KB / Downloads: 7)
Antwortento top
#2
Hallo Highlander90,

man kann das F-System berechnen für einen Eintragungswert z.B. in B2.
Dafür z.B. folgende Formel in Deiner verbundenen Zelle A2:A4


Code:
=WENNFEHLER(VERWEIS(9;1/(ZEILE('F-Systemkatalog'!A1:A99)<=VERGLEICH(B2;'F-Systemkatalog'!B2:B99;0))/
('F-Systemkatalog'!A1:A99<>"");'F-Systemkatalog'!A:A);"")

Für die Zellen in B3 und B4 würde ich vorschlagen diese in Abhängigkeit dee für B2 ermittelten F-Systems in A2 zu ermitteln. Denn bei Deiner angedachten Lösung könnten aus Versehen verschiedene "E-Systemwerte in B2:B4 gewählt werden, was dann zu keiner eindeutigen "F-System"-Wert führt.

[Nachtrag]
es gibt es in Deinem Systemkatalog auch "F-Systeme mit 4 anstelle nur 3 "E-System"-Daten. Du müsstest also dann schon A2:A5 verbinden und B5 bleibt eben bei den mit nur drei Werten frei.
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Highlander90
Antwortento top
#3
Hallo neopa,

vielen Dank für deine Antwort.

Ich glaube ich habe mich in meiner anfänglichen Beschreibung falsch ausgedrückt oder verstehe deine Ausführung falsch.

Ein F-System besteht immer aus 3 (oder wie du richtig angemerkt hast, aus 4) E-Systemen. Diese 3 oder 4 E-Systemen müssen immer zusammen auftreten um ein F-System zu bilden.

Als Beispiel: die E-Systeme ES_A_GR1.01_1, ES_S_GR1.01_1 und ES_A_GR1.01_2 bilden nur zusammen das F-System FS_FU_GR1.01.
Die Angabe eines einzelnen E-Systems bildet kein F-System. Ein E-System kann aber Bestandteil von verschiedenen F-Systemen sein.

Daher ist die Zuordnung eines E-Systems zu nur einem F-System nicht möglich. Nur die spezifische Kombination der E-Systeme wie sie im 2. Tabellenblatt hinterlegt ist bringt ein F-System hervor.

Ist es also möglich, dass in Zelle A2 der Name des jeweiligen F-Systems auftaucht, sobald die passende Kombination an E-Systemen in den Zellen B2 bis B5 auftaucht?




Liebe Grüße
Antwortento top
#4
Hier nochmals die veränderte Beispieldatei.


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 15,82 KB / Downloads: 4)
Antwortento top
#5
Hola,

zur Info...

https://www.ms-office-forum.net/forum/sh...p?t=357777

Gruß,
steve1da
[-] Folgende(r) 1 Benutzer sagt Danke an steve1da für diesen Beitrag:
  • Storax
Antwortento top
#6
(04.02.2019, 18:59)steve1da schrieb: Hola,

zur Info...

https://www.ms-office-forum.net/forum/sh...p?t=357777

Gruß,
steve1da

Hallo,

Offen gestanden, denke ich dass dies wenig hilfreich ist.
Siehe:
https://www.ms-office-forum.net/forum/sh...ost1912702

Das Danke von Storax setzt dem noch die Krone auf.

Denkt doch bitte einmal über die Grundidee dieser Foren nach.

Viele Grüße,
Bernd P
Antwortento top
#7
Entsprechende User in die "Ignorehölle" verschoben 19
Hier geht es weiter
Antwortento top
#8
Hallo Highlander90,

mich interessierte eine Formellösungsmöglichkeit. Eine solche hab ich nun mal aufbereitet. Momentan ging ich davon aus, dass im Katalog nur bis zu 98 Datensätze erfasst sind und zwar mit "3er" und "4er"-E-Systeme gemischt. Eine Anpassung auf bis ca. 1000 sollte noch vertretbar sein. Für Massendatenauswertung (tausend und mehr F-Systeme) bedarf es jedoch  einer anderen Auswertungsmethode.

Um meine nachfolgende Formellösung überschaubar(er) zu halten, hab ich eine Hilfsspalte im Katalog-Tabellenblatt eingeführt und arbeite mit benannten Formeln. Diese sollte bei aktivierter Zelle B2 im Namensmanager definiert werden.

Die Hilfsspaltenformel ist bis zum Datensatzende ziehend nach unten zu kopieren. Die Hilfsspalte selbst kann anschließend ausgeblendet werden.

Die bedingten Formatierungen in der Eingabe sind lediglich zur visuellen Eingabekontrolle vorgesehen aber nicht notwendig.

Bei Rückfragen kann ich wohl frühestens morgen reagieren, weil ich gleich offline gehen muss.

Arbeitsblatt mit dem Namen 'F-Systemkatalog'
ABCDE
1F-SystemE-SystemHilfssp.
2F-System 1E-System 1
3E-System 2
4E-System 3
5F-System 2E-System 1
6E-System 2
7E-System 4
8F-System 3E-System 1
9E-System 3
10E-System 4
11F-System 4E-System 1
12E-System 4
13E-System 6
14F-System 5E-System 20
15E-System 6
16E-System 3
17E-System 1
18F-System 6E-System 218
19E-System 6
20E-System 4
21E-System 1
22F-System 7E-System 2
23E-System 3
24E-System 4
25F-System 9E-System 10
26E-System 2
27E-System 3
28E-System 4
29

NameBezug
_EingAnz=ANZAHL2(Eingabe!$B$2:$B$5)
_EingZae=SUMMENPRODUKT(ZÄHLENWENN(Eingabe!$B$2:$B$5;Eingabe!$B$2:$B$5))
_ESysAusw=SUMMENPRODUKT(ZÄHLENWENN('F-Systemkatalog'!$B1:INDEX('F-Systemkatalog'!$B:$B;WENNFEHLER(_FSysTeil+ZEILE('F-Systemkatalog'!$A1048576);_KatEnd-1));Eingabe!$B$2:Eingabe!$B$5))
_FSysTeil=VERGLEICH(1;INDEX(0+('F-Systemkatalog'!$A2:$A5>0););0)
_KatEnd=VERWEIS(9;1/('F-Systemkatalog'!$B$1:$B$99<>"");ZEILE('F-Systemkatalog'!$B$2:$B$99))

ZelleFormel
E2=WENN(($A2="")+($B2="")+(WENNFEHLER(_FSysTeil+ZEILE();_KatEnd)-ZEILE()<>_EingAnz)+(_EingZae<>_EingAnz);"";ZEILE()*(_ESysAusw=_EingAnz))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

Arbeitsblatt mit dem Namen 'Eingabe'
AB
1F-SystemE-System
2F-System 6E-System 2
3E-System 4
4E-System 1
5E-System 6

NameBezug
_FSysNr=WENN(MAX('F-Systemkatalog'!E:E)=0;"";INDEX('F-Systemkatalog'!A:A;MAX('F-Systemkatalog'!E:E)))

ZelleFormel
A2=_FSysNr

Zellebedingte Formatierung...Format
B21: ZÄHLENWENN(B$2:B$5;B2)>1abc
B22: (ZÄHLENWENN($B$2:$B$5;"")>1)*(B2=0)abc
B31: ZÄHLENWENN(B$2:B$5;B3)>1abc
B32: (ZÄHLENWENN($B$2:$B$5;"")>1)*(B3=0)abc
B41: ZÄHLENWENN(B$2:B$5;B4)>1abc
B42: (ZÄHLENWENN($B$2:$B$5;"")>1)*(B4=0)abc
B51: ZÄHLENWENN(B$2:B$5;B5)>1abc
B52: (ZÄHLENWENN($B$2:$B$5;"")>1)*(B5=0)abc

ZelleGültigkeitstypOperatorWert1Wert2
B2ListeE-System 1; E-System 2; E-System 3; E-System 4; E-System 5; E-System 6
B3ListeE-System 1; E-System 2; E-System 3; E-System 4; E-System 5; E-System 6
B4ListeE-System 1; E-System 2; E-System 3; E-System 4; E-System 5; E-System 6
B5ListeE-System 1; E-System 2; E-System 3; E-System 4; E-System 5; E-System 6
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Gruß Werner
.. , - ...
[-] Folgende(r) 1 Benutzer sagt Danke an neopa für diesen Beitrag:
  • Highlander90
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste