Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

verschachtelte WENN Funktion
#1
Grüße,
ich habe gerade die kleine Herausforderung, dass ich eine Auswertung für Laufdaten erstellen möchte.

Ich habe in Zeile 1 die Läufe eingetragen, also Lauf 1 in Zelle A1, Lauf 2 in Zelle B1 usw. bis Zelle E1.
Die Ergebnisse stehen dann in Zeile 2. Wobei nur zwischen, "x" für bestanden, "o" für nicht bestanden und Leere für nicht absolviert, unterschieden wird
Die Auswertung soll dann in Spalte F erfolgen. 
Ohne "o" für nicht bestanden, ist es soweit auch noch recht einfach:
=WENN(A2="x";WENN(B2="x";WENN(C2="x";WENN(D2="x";WENN(E2="x";"x";"")))))
Somit sehe ich auf einem Blick, ob ein Lauf ausgelassen wurde, oder alle Läufe bestanden sind.
Wie muss ich die Funktion verändern, damit sie mir in der Auswertung auch auf einem Blick sagt das ein Lauf zwar durchgeführt aber nicht bestanden wurde ("o").


Mit freundlichem Gruß
Max
Antwortento top
#2
Hallo Max,

Zitat:Ich habe in Zeile 1 die Läufe eingetragen, 
Die Ergebnisse stehen dann in Zeile 2.

ganz schlechter Ansatz. In Excel gilt, ein Datensatz - eine Zeile. Wenn du das nicht beachtest, wirst du mit jeder Art Auswertung früher oder später scheitern. Sehr wahrscheinlich früher …

PS: oder stehen in Zeile 1 die Spaltenüberschriften?
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#3
(29.01.2019, 18:10)Klaus-Dieter schrieb: PS: oder stehen in Zeile 1 die Spaltenüberschriften?

Ja genau, hab mich da schlecht ausgedrückt.
Antwortento top
#4
Hallo Max,

OK, verstanden. Wie viele o sind erforderlich für nicht bestanden? Oder sollen alle möglichen Optionen für sich ausgewertet werden?

Also zum Beispiel so:

Tabelle1

ABCDEFGH
1Lauf 1Lauf 2Lauf 3Lauf 4Lauf 5xo
2oxx212
3oooo041
4xoox221
5ooox131
6xoxx311
7xx203
8ooxoo140
9oox122
10oox122
11o014
Formeln der Tabelle
ZelleFormel
F2=ZÄHLENWENN($A2:$E2;F$1)
G2=ZÄHLENWENN($A2:$E2;G$1)
H2=5-SUMME(F2:G2)

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#5
Also in die Spalte F darf nur ein x kommen, wenn alle läufe absolviert und bestanden sind.
Ein o soll angezeigt werden, sobald auch nur ein Lauf zwar absolviert, aber nicht bestanden wurde.
Und die Zelle soll leer bleiben, sobald ein Lauf ausgelassen wurde.
Antwortento top
#6
Hallo,

dann so:

Tabelle1

ABCDEF
1Lauf 1Lauf 2Lauf 3Lauf 4Lauf 5
2xxxxxx
3oooo
4xxooxo
5ooox
6xoxx
7xxxoxo
8ooxooo
Formeln der Tabelle
ZelleFormel
F2=WENN(ZÄHLENWENN($A2:$E2;"x")=5;"x";WENN(ZÄHLENWENN($A2:$E2;"")>0;" ";WENN(ZÄHLENWENN($A2:$E2;"o")>0;"o")))

Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
[-] Folgende(r) 1 Benutzer sagt Danke an Klaus-Dieter für diesen Beitrag:
  • Emtec
Antwortento top
#7
Thumbs Up 
Danke, das war genauso wie ich es brauchte.
Antwortento top
#8
Guten Morgen,
ich habe da leider doch noch ein Problem.
Und zwar generiert sich das x und das o in den Zellen aus einer Funktion heraus und ich dachte nicht, dass es eine Rolle spielt. Confused
Hab jetzt auf Arbeit deine Funktion in der Tabelle angewandt und sie kommt zu keinem Ergebniss.
Die Tabelle hier, sieht natürlich anders aus als das Beispiel was ich zuhause gemacht habe.

Hier sind die Spaltenüberschriften in Zeile 119 in den Spalten C bis H und die Auswertung ist in Spalte I.
Die Funktionen in den Zellen sind:
C120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";I2;0)))
D120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";J2;0)))
E120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";K2;0)))
F120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";L2;0)))
G120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";M2;0)))
H120: =WENN(D2="m";WENN(H2="x";WENN(F2<>"O";N2;0)))

In D2 wird das Geschlecht definiert, in H2 wird definiert ob die betrachtet wird und F2 schließt eine bestimmte Gruppe aus deren Daten woanders zwar mit aufgenommen werden aber für Auswertung nicht relevant sind.

Deine Formel hab ich folgendermaßen angepasst:
=WENN(ZÄHLENWENN($C120:$H120;"x")=5;"x";WENN(ZÄHLENWENN($C120:$H120;"")>0;" ";WENN(ZÄHLENWENN($C120:$H120;"o")>0;"o")))

Als Ergebniss erhalte ich dennoch immer FALSCH.
Antwortento top
#9
Hallo, da fehlt beim letzten WENN() die Sonst_Bedigung... i.Ü. schon bei Klaus-Dieters Formel...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Emtec
Antwortento top
#10
Was steht denn in Zeile 120 in Spalte C-H? Steht da x, o oder FALSCH?

Ansonsten sollte es mit Jockels Hinweis klappen!

Gruß
Sebastian
[-] Folgende(r) 1 Benutzer sagt Danke an Bast4i für diesen Beitrag:
  • Emtec
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste