Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Richtige Funktion wählen. Dringend !!!
#1
Music 
Hallo,

ich habe ein Riesen Problem und zwar muss ich eine kleine Auswertung machen und bin aber in Excel nicht ganz so bewandert mit allen Funktionen.

In Spalte a stehen die selben Produktname wie in Spalte G. Ich hätte gern das er die beiden Spalten vergleich und den Wert aus H in D ausgibt. Ich habe schon einige versucht aber meistens kommt ein Inkorrektes Ergebnis raus oder er gibt falsche Zahlen aus weil angeblich etwas nicht nach Größe sortiert ist. Ich habe mal ein Bild angehangen. Vielleicht kann mit jemand helfen?! Wäre echt super denn es sind fast 3000 Positionen die ich sonst per Hand eingeben müsste


Angehängte Dateien Thumbnail(s)
   
Antwortento top
#2
Hola,

dann schau dir ganz ganz schnell den Sverweis an.


https://www.online-excel.de/excel//singsel.php?f=9

Gruß,
steve1da
Antwortento top
#3
Hallo,

du hättest die Zeit bis zu einer brauchbaren Antwort beschleunigen können, wenn du anstelle des Bildes eine Beispieldatei eingestellt hättest.
Viele Grüße
Klaus-Dieter
Der Erfolg hat viele Väter, 
der Misserfolg ist ein Waisenkind
Richard Cobden
Antwortento top
#4
(28.01.2019, 11:22)leipzig schrieb: Hallo,

ich habe ein Riesen Problem ...
In Spalte a stehen die selben Produktname wie in Spalte G.

Hallo, das glaube ich, weil das nicht so aussieht...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top
#5
Ja ich weiß das es nicht gleich aussieht weil in der einen Spalte die Artikelnummer mit steht aber vielleicht gibt es ja doch eine Möglichkeit?

Aus SVerweis werde ich nicht wirklich schlau. Wie gesagt kenne mich nicht wirklich damit aus.

Würde mich aber dennoch freuen eine simple Antwort zu bekommen die ein Laie versteht.

Danke
Antwortento top
#6
Hola,

Code:
=SVERWEIS(TEIL(A3;FINDEN("]";A3)+2;199);$G$3:$H$5000;2;9)

Gruß,
teve1da
Antwortento top
#7
http://www.excel-ist-sexy.de/eilt-wichtig/
Antwortento top
#8
Hallo steve1da

habe die Formel eingesetzt aber er bringt überall als Ergebnis 0?!
Antwortento top
#9
Hola,

dann wird der Wert aus A3 zwar gefunden, aber in H steht dann nichts drin.
Am Ende muss aus der 9 übrigens eine 0 werden, das sollte hier aber nichts am Ergebnis ändern.
Code:
=SVERWEIS(TEIL(A3;FINDEN("]";A3)+2;99);$G$3:$H$5000;2;0)

Gruß,
steve1da
Antwortento top
#10
Hallo                       Lösung nach dem Aschenputtel Prinzip  ...   "die guten ins Töpfchen"

anbei eine Beispieldatei mit einer Makro Lösung. Leider gab es keine Beispieldatei vom Frager, dann konnte ich das Makro mit richtigen Daten testen.  Meine Lösung könnte sehr interessant sein.  Für interessierte Kollegen gibt es auch eine xlsx Datei mit Makro in der Tabelle.

Ich bitte den Frager seine Daten ins Beispiel zu kopieren, denn ich benötige zum Auswerten sechs Hilfsspalten und vier Spalten um eine Fehlerliste der Schreibfehler zu erstellen.  Die Spalten wie im Bild sind oben in der 1. Zeile angegeben.  

PS  Eine Sache habe ich im Makro vergessen, die Lauf Nr. von 1 bis xxx in Spalte A + K automatisch einzufügen. Das muss man von Hand machen über die Funktion "Füllen" im 1. Menü.  Eine 1 in Zelle A5 + K5 und dann füllen lassen.  Bitte VOR dem Drücken des 1. Button  "Test Vollprüfung 

Nach dem Kopieren der Daten und drücken des 1. Buttons Rechts "Text Vollprüfung" dürfte für den User eine interessante Überraschung kommen.  Mindestens 1-2000 Daten sind plötzlich weg!!  Nicht verloren, sondern bei 100% Übereinstimmung werden sie sofort ins Blatt  "Gute Daten"  kopiert, damit man nur noch die -Unstimmigen Daten- im Blatt hat.  Ich nenne es das "Aschenputtel Prinzip, die guten ins Töpfchen.." 

Der zweite Button macht dann die Auswertung mit Teilweiser Übereinstimmung. D.h., der Produkt Code kann übereinstimmen, der Produkt Text, aber irgendwo gibt es Abweichungen, z.B. Tippfehler etc.  Diesen Datensatz muss man vor dem Kopieren mit dem Button Oben in der Mitte manuell prüfen.  In Spalte H + I gibt es die "Daten Find Notiz".  Bei Übereinstimmung bekommt der Datensatz im rechten Block und linken Block die gleiche Nummer!

Durch dieses Verfahren, den Datensatz neu zu numerieren, kann ich verschobe Datensaetze wieder in eine Zeile bringen. Das Makro interessiert ein Zeilen Unterschied nicht.  Zum Bearbeiten kann man die Daten auch sortieren.  Sollen Daten nicht in "Gute Blatt" kopiert werden muss man in Spalte H + I die Nummer entfernen.  Rechts sind vier Spalten mit Fehler Hinweisen auf Schreibfehler für jeden Datensatz. Es erleichtert die Daten zu korrigieren.

Das Sortier Makro hat auch eine Besonderheit. Der Linke Block sortiert den ganzen Bereich, auch die Spalten J bis N.  Die Button ab J sortieren nur den Rechten Bereich, damit man verschobene Daten durch sortieren richtig stellen kann. Leider konnte ich das Makro mangels Daten nicht richtig testen.  

Der Datensatz in "Gute Daten" entspricht dem Datensatz wie im Bild. Ich habe nur Die Spalte A für eine Lauf Nr. vorgesehen.  Es würde mich freuen wenn diese Arbeit euch weiterhilft den "Datensalat" wieder in Ordnung zu bringen.

mfg  Gast 123


Angehängte Dateien
.xlsm   Richtige Funktion 2.xlsm (Größe: 28,4 KB / Downloads: 0)
.xlsx   Richtige Funktion.xlsx (Größe: 16,59 KB / Downloads: 0)
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste