Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Rotationsplan
#1
Hallo zusammen!

Ich bräuchte bitte wieder einmal ein bisschen Hilfe...

Und zwar möchte ich aus meinem Schichtplan einen Inspektionsplan generieren!
Es soll jeden Tag aus dem arbeitenden Personal eine Rangliste erstellt werden, die eine Person festlegt, die, die Inspektion an der Maschine macht! Diese Person soll so gut es geht jeden Tag eine Andere sein! Zudem sollte eben eine Rangliste entstehen, damit eine andere Person aufrückt falls diese Person ausfällt!
Ich hab schon etwas hinbekommen, aber nicht ganz zufrieden stellend, da sich einige Mahle doch Wiederholungen ergeben, die nicht sein müssten..
Vielleicht hätte mir jemand Hilfe.. 

Im Anhang die Beispieldatei


Angehängte Dateien
.xlsm   Ges BSP.xlsm (Größe: 31,38 KB / Downloads: 10)
Eine Menge reden, aber nichts sagen können viele...
Antwortento top
#2
Hi Frogger,

mein Vorschlag.

Im Blatt Inspektion in A6
=INDEX('S-RIM'!$22:$28;ZEILE($A1);VERGLEICH("FIX";'S-RIM'!$3:$3;0)-14+SPALTE())       bis N12 kopieren.

Zeile 13 ist eine leer Zeile

A14   =WENN(A6=0;"";A6)   kopieren bis A20

B14   =WENN(SUMME(1*(B$6:B$12<>0))>=ZEILE($A1);INDEX(B$6:B$12;VERGLEICH(KKLEINSTE((B$6:B$12=0)*1000+ZÄHLENWENN($A$14:A14;B$6:B$12)+ZÄHLENWENN(B$13:B13;B$6:B$12)*100;1);(B$6:B$12=0)*1000+ZÄHLENWENN($A$14:A14;B$6:B$12)+ZÄHLENWENN(B$13:B13;B$6:B$12)*100;0););"")       'strg+shift+Enter und bis N20 kopieren
[-] Folgende(r) 1 Benutzer sagt Danke an Elex für diesen Beitrag:
  • Frogger1986
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste