Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summenprodukt mit Datumsabgleich
#1
Hallo zusammen,

ich möchte gerne mit Summenprodukt Daten auf einer Monatsachse zusammenfassen,
die Summen sollen anhand der berechneten Kalenderwochen und dem Monat in einer
Monatsspalte zusammegefasst werden.

In der Anlage einmal die Beispieldatei.

Beide Versuchen klappen nicht richtig.

1. Versuch kann nicht gehen, da das Datum der KW auf jeden Montag berechnet wird und somit
unterschiedliche Daten (7.1.19...14.1.19) innerhalb des Monats mit dem Beispiel 01.01.19 nicht übereinstimmen.

Im 2 . Versuch wollte ich bezwecken, das nur der Monat abgeglichen wird und bei Übereinstimmung
nur die Summe des Monats, also in dem Beispiel KW 2-KW 5 summiert werden.

Hat aber wie zu sehen auch nicht geklappt - er summiert dann alle Werte auch Feb 19 etc.

Kann jemand helfen oder hat eine gute Idee?
Vielen Dank im Voraus und ein schönes Wochenende allen.

Excelmonsta


Angehängte Dateien
.xlsx   Beispiel Summenprodukt mit datum.xlsx (Größe: 10,18 KB / Downloads: 8)
Antwortento top
#2
Hallo, meinst du so..:?

PHP-Code:
=SUMMENPRODUKT((TEXT($F$3:$L$3;"JJMM")=TEXT(B10;"JJMM"))*1;$F$6:$L$6
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
[-] Folgende(r) 1 Benutzer sagt Danke an Jockel für diesen Beitrag:
  • Excelmonsta
Antwortento top
#3
Hallo,

evtl.  (bin mir nicht sicher, ob es in Excel 2007 schon die Funktion MONATSENDE() gab)
alternativ zur Lösung von Jörg in B11

Code:
=SUMMENPRODUKT(($F3:$Z3>=B10)*($F3:$Z3<=MONATSENDE(B10;0));$F6:$Z6)

und Formel ebenfalls nach rechts kopieren.
Gruß Werner
.. , - ...
Antwortento top
#4
Hallo Jörg,

super - Top Lösung, wie immer von dir! Vielen Dank.

Verstehe, du hast mit dem Text davor sozusagen nicht die Übereinstimmung
des exakten Datums, sondern des dargestellten Textes - welches ja teilweise
gleich ist abgefragt. Dann passt es - werd ich mir (versuchen ;Wink zu merken.

Liebe Grüße
Antwortento top
#5
Danke für's feedback; wenn du es dir nicht merkst - frag einfach (nochmal) (^_-) ...
Gruß Jörg

"Wer immer tut, was er schon kann, bleibt immer das, was er schon ist." - Henry Ford
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste