Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Zu viele Verschachtelungen
#1
Er soll mir aus einer Datei alle https Dateien aus einer Exceldatei ausgelesen und hintereinander durch einen | getrennt darstellt werden.
z.B

Dateien bitte im Forum hochladen: https://www.clever-excel-forum.de/thread-326.html

Leider ist meine Verschachtelung zu groß, hat einer eine Idee?
Die CSV Datei aus der ich das auslese beinhaltet mehrere Spalten aus denen die Bilder in die eine Zelle des neuen Datei geladen werden soll. Hier ist der Quellcode dieser



=WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;8;FALSCH) =0;"";(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;8;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;8;FALSCH)= 0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;8;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;9;FALSCH)= 0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;9;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;10;FALSCH) =0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;10;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;11;FALSCH) =0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;11;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;12;FALSCH) =0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;12;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;13;FALSCH) =0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;13;FALSCH);

WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;14;FALSCH) =0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;14;FALSCH)


Danke im Voraus! Ich hoffe einer kann helfen!
Antwortento top
#2
Hola,

das mit den Bildern hast du wieder vergessen?

https://www.ms-office-forum.net/forum/sh...p?t=356106

Gruß,
steve1da
Antwortento top
#3
Hallo M...,

das sind nicht zuviele Verschachtelungen, sondern zuviele Parameter. Die Wenn-Funktion hat nur drei Parameter.
Das hat steve1da doch schon im MS Office Forum geschrieben.

Ersetze "FALSCH);" durch "FALSCH)&".
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top
#4
Das habe ich schon gemacht "&" am Ende außer es ist falsch

=WENN(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;7;FALSCH)=0;"";"|"&(SVERWEIS(A19;eksa_trade_allgemein_alle_produkte.csv!$A$2:$Y$3204;7;FALSCH)))&

mehr als 7 Verschachtelungen läßt dieser nicht zu!
Ich will aber 10 Bilder in der einen Zelle abspeichern bzw. abbilden!




Danke Helmut
Antwortento top
#5
(30.11.2018, 15:38)MickNolte schrieb: Er soll mir aus einer Datei alle https Dateien aus einer Exceldatei ausgelesen...
Erstmal: Hallo. Und dann wer ist "er"..?
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#6
Egoisten wie du sind mir echt ein Gräuel...
Schöne Grüße
Berni
Antwortento top
#7
bißchen doof ausgedrückt, egal!
Antwortento top
#8
Es gibt viele Egoisten im Leben, so ist das Leben! Im Straßenverkehr, in der Politik, der Wähler, der seit Jahrzehnten den Müll gewählt hat, wer ist hier ein Egoist?
Antwortento top
#9
Danke für die Nichthilfe, habe die Lösung selbst gefunden!
Antwortento top
#10
Hallo m...,

zu
Zitat:... wer ist hier ein Egoist?

Du
helmut

Für mich ist die Möglichkeit in Excel an Zellen und Bereichen Namen zu vergeben die wichtigste Funktionalität.
Sie macht Formeln und den VBA-code verständlicher. Für Makros gilt die Regel: "Nur über benannte Bereiche auf den Inhalt der Zellen zugreifen."
Und wofür sind Regeln da? Um nachzudenken bevor man sie bricht.





Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste