Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Summewenn Funktion
#1
Hallo Forum, 

ich bräuchte bitte eure Hilfe.

Ich habe:
Spalte A = Verteiler (Angebote, Check,Paradies,Vergleich)
Spalte B = Affinitäten (astro, auto, finanzen und beauty)
Spalte C = Ziel (25% 20% ...)

Ich möchte das wenn in Spalte A ein Verteiler ausgewählt wird und in Spalte B die Affinität, das Spalte C gezählt und wiedergegeben wird. 

Meine aktl. Formel sieht so aus :

=WENN(UND(A2:A9="Angebote";B2:B9="astro");SUMMEWENN(B2:B9;"astro";C2:C9);"falsch")

Beispiel habe ich mit angehängt.

Danke schon mal.


Angehängte Dateien
.xlsx   beispiel.xlsx (Größe: 15,94 KB / Downloads: 4)
Antwortento top
#2
Hallo, meinst du so..?

Arbeitsblatt mit dem Namen 'Tabelle1'
EFGHIJKL
10AngeboteCheckParadiesVergleich
11astroautoastroautobeautyfinanzenbeautyfinanzen
1225%57%56%20%34%40%87%48%

ZelleFormel
E12=SUMMEWENNS($C$2:$C$9;$A$2:$A$9;INDEX($E$10:$L$10;;SPALTE(A1)-REST(SPALTE(B1);2));$B$2:$B$9;E$11)
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.01] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top
#3
Hola,

Code:
=SUMMEWENNS(C2:C9;A2:A9;E10;B2:B9;E11)

Gruß,
steve1da
Antwortento top
#4
Hi,

das geht auch mit PivotTable:

Arbeitsblatt mit dem Namen 'Tabelle1'
EFGHIJKLMNOPQRS
6
7Summe von ZielSpaltenbeschriftungen
8ZeilenbeschriftungenAngeboteCheckParadiesVergleich
9astro25%56%
10AngeboteCheckParadiesVergleichauto57%20%
11astroautoastroautobeautyfinanzenbeautyfinanzenbeauty34%87%
1225%57%56%20%34%40%87%48%finanzen40%48%
13
14

ZelleFormel
E12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$E$10;"affinität";E11)
F12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$E$10;"affinität";F11)
G12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$G$10;"affinität";G11)
H12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$G$10;"affinität";H11)
I12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$I$10;"affinität";I11)
J12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$I$10;"affinität";J11)
K12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$K$10;"affinität";K11)
L12=PIVOTDATENZUORDNEN("Ziel";$N$7;"Verteiler";$K$10;"affinität";L11)
Verwendete Systemkomponenten: [Windows (32-bit) NT 10.00] MS Excel 2016
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg

.xlsx   Beispiel-2.xlsx (Größe: 15,37 KB / Downloads: 1)

oder mit SUMMENPRODUKT.
Antwortento top
#5
Hallo Ralf, für deine Lösung mit PIVOTDATENZUORDNEN() braucht's ja zusätzlich eine PivotTable... und SUMMENPRODUKT() ist die schlechtere Wahl gegenüber SUMMEWENNS() aber als alternative Vorschläge okay.

Bei einem anderen möglichen Zielszenario sehe ich aber auch PivotTable oder Power Query vorne.
cu Jörg eine Rückmeldung wäre ganz reizend XL2003 bis XL2019
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste