Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

Symbole ausgeben mit TEIL/ wechselnde Zugehörigkeit
#1
Hallo Zusammen,
Ich habe eine Liste mit Strings pro Zelle in Spalte A. Ausgabe in B soll X oder [] sein.
Nun soll diese Ausgabe immer im wechsel erfolgen, sodass die übereinander zusammengehörigen Nummern schnell ersichtlich sind. (Zieltabelle ist groß und unübersichtlich)
Habe auch schon die bedingte Formatierung versucht, aber die Nummern ändern sich fortlaufend, deswegen eher unpraktisch.
Bisherige Formel für Spalte B: =WENN(TEIL(A3;6;2)=TEIL(A2;6;2);"X";"[]")
Ziel:
S-1001/X
S-2001/X
S-3001/X
S-1002/[]
S-2002/[]
S-1003/X
.......

Bin für jede Hilfe dankbar ;)


Angehängte Dateien
.xlsx   Symbole.xlsx (Größe: 11,26 KB / Downloads: 3)
Antwortento top
#2
Hallo, mal ein Gedanke:
deine Formel etwas umgestellt und runter kopiert, würde die Anzahl der Blöcke zählen:
=SUMMENPRODUKT((TEIL($A$3:A3;5;2)<>TEIL($A$2:A2;5;2))*1)

Das ganze durch Rest() erweitert in die Bedingte Formatierung und die Blöcke werden abwechselnd eingefärbt
Gruß Holger


Angehängte Dateien
.xlsx   Symbole.xlsx (Größe: 18,55 KB / Downloads: 4)
[-] Folgende(r) 1 Benutzer sagt Danke an echo für diesen Beitrag:
  • hanso686
Antwortento top
#3
Danke das funktioniert sehr gut 18
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste