Dieses Forum nutzt Cookies
Dieses Forum verwendet Cookies, um deine Login-Informationen zu speichern, wenn du registriert bist, und deinen letzten Besuch, wenn du es nicht bist. Cookies sind kleine Textdokumente, die auf deinem Computer gespeichert werden. Die von diesem Forum gesetzten Cookies werden nur auf dieser Website verwendet und stellen kein Sicherheitsrisiko dar. Cookies aus diesem Forum speichern auch die spezifischen Themen, die du gelesen hast und wann du zum letzten Mal gelesen hast. Bitte bestätige, ob du diese Cookies akzeptierst oder ablehnst.

Ein Cookie wird in deinem Browser unabhängig von der Wahl gespeichert, um zu verhindern, dass dir diese Frage erneut gestellt wird. Du kannst deine Cookie-Einstellungen jederzeit über den Link in der Fußzeile ändern.

ZÄHLENWENN erst ausführen, wenn eine Bedingung erfüllt ist
#1
Ich komme mit meinem Problem nicht weiter. Excel 2013.
Einen Teil habe ich fertig, wenn es denn so richtig ist.
In Spalte C (1-6) sollen Sternchen als Kennzeichnung der doppelten Werte angezeigt werden, aber nur dann, wenn in A1 eine 1 steht. Steht in A1 eine 2, soll ein Pfeil angezeigt werden.


Angehängte Dateien
.xlsx   Mappe1.xlsx (Größe: 9,17 KB / Downloads: 10)
Antwortento top
#2
Hola,

=wenn(A1=1;Dann;Sonst)

Gruß,
steve1da
Antwortento top
#3
Hallo "steve1da",
Danke für Deine Antwort,
trotz mehrerer Versuche bekomme ich das nicht hin. Wie sieht denn Deine Formel komplett aus.
Hier nochmal der erste, funktionierende Teil.
In Spalte C (1-6) sollen Sternchen als Kennzeichnung der doppelten Werte von Spalte D1:D6 angezeigt werden, aber nur dann, wenn in A1 eine 1 steht. Steht in A1 eine 2, soll ein an Stelle des Sternchens ein Pfeil oder ein anderes Zeichen angezeigt werden, damit der Benutzer direkt sehne kann, was er tun muss.
Die Formel in C1:C6 lautet: =WENN(UND(ZÄHLENWENN($D$1:$D$6;D1)>1;D1<>"");"*";"")
Was ich nicht hinbekomme ist, dass diese Zählfunktion abhängig ist vom Eintrag in A1.
Antwortento top
#4
Mal salopp gesagt: Du fügst einfach deine bisherige Formel für das "Dann" ein und für das "Sonst" deinen Pfeil.
Antwortento top
#5
@ cadmus

manchmal sieht man den Wald vor lauter Bäumen nicht.

Ein Teil funktioniert jetzt wunderbar, ich hoffe, den Rest bekomme ich auch noch hin.

Vielen Dank an alle.
Antwortento top
#6
Hi,

also so?
=WENN(A1=1;WENN(UND(ZÄHLENWENN($D$1:$D$6;D1)>1;D1<>"");"*";"");WENN(UND(ZÄHLENWENN($D$1:$D$6;D1)>1;D1<>"");"Pfeil";""))
Antwortento top
#7
WAHL geht auch.


Code:
=WENNFEHLER(WAHL(A1;WENN(UND(ZÄHLENWENN($D$1:$D$6;D1)>1;D1<>"");"*";"");"->");"")
Antwortento top


Gehe zu:


Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste